11

Some, but not all, icons for UWP apps are not displaying in search or settings. They do, however, display on the start menu when not searching. Icons for all non UWP apps display correctly, every time. UWP app icons are always present on the taskbar.

UPDATE: Many locally stored image thumbnails fail to appear in start menu search results either, no matter what image format.

The reason I have posted this as a separate question from this thread, is for the following differentiating reasons:

  • Not all UWP app icons fail to display
  • The issue is specifically present on the start menu only during search
  • UWP apps never fail to display their icons on the taskbar

I have tried:

  • Resetting the icon cache
  • The solution here involving the windowsapps folder
  • Creating a new user account
  • Deleting iconstream registry keys
  • Changing performance settings to save thumbnails

  • Changing default app for PNGs

  • Changing default app for all images in windows settings
  • Changing windows explorer view settings
  • Updating graphics drivers

Screenshots:
Search failing to display icon
Some icons failing to display in settings

15

For years, I've had the exact same issues with app thumbnails. Particularly for Metro-style apps (RT/UWP), I often see a blank or default icon, primarily in search results and settings. I've been troubleshooting it for years, with no success until now. I'm documenting this here because I know I'm going to encounter it again. When I search for a solution, I'll hopefully find this page.

Background

In Windows 10, UWP apps are shipped as AppX packages. This includes many of the new built-in apps (stored in %SystemRoot%\SystemApps) as well as apps downloaded via Windows Store (stored in %ProgramFiles%\WindowsApps). PowerShell offers several cmdlets that are useful for managing AppX packages. Throughout my troubleshooting, I found Get-AppxPackage, Add-AppxPackage, and Remove-AppxPackage particularly useful, especially since %ProgramFiles%\WindowsApps is inaccessible to normal users, even administrators.

Before attempting these fixes, you should be comfortable editing the registry, working with the command prompt and PowerShell, and making backups. You should be prepared to wipe everything and reinstall Windows should something go wrong.

Issue 1: Third-party thumbnail handlers for .png

Some third-party apps like to install custom thumbnail generators. Some of these apps do so in a way that breaks things. In my case, Google's Drive File Stream was the culprit. Keep in mind that this is different from having a default program for a file; Windows Photos remained the default for me. To solve the issue:

  1. Run: regedt32.exe
  2. Navigate to: HKEY_CLASSES_ROOT\.png
  3. Look for a ShellEx key with at least one subkey. If you see any subkeys, you've probably found the culprit.
  4. Delete the subkeys.
  5. Restart File Explorer.

Here's a screenshot of what you should be deleting. Note that the actual key might not be named {E357FCCD-A995-4576-B01F-234630154E96}; it'll depend on the application responsible for the issue.

Registry key to be deleted

This may seem like an obscure fix, but the issue stems from the fact that AppX package logos are typically stored as PNG files. When this issue arises, you may also notice that PNG files are lacking proper thumbnails (you won't see previews while browsing folders in File Explorer). If the app causing the problem has installed similar handlers for other image file types, you can perform the same steps as above to the affected file extensions to restore the thumbnails. Keep in mind that this may affect the functionality of the app, so you may have to make a trade-off.

Issue 2: Thumbnails are disabled in Performance Settings

  1. Right-click on the Start Menu icon or press Windows + X.
  2. A menu will appear. Click System.
  3. Under the Related settings pane on the right, click the System info link.
  4. Click the Advanced system settings link in the pane on the left.
  5. The Advanced tab should already be selected in the resulting dialog.
  6. Click Settings... in the Performance group.
  7. Ensure Show thumbnails instead of icons is checked.

Issue 3: Thumbnails are disabled in Folder Options

  1. Open a File Explorer window.
  2. In the View ribbon tab, click the Options button on the right.
  3. Select the View tab in the resulting dialog.
  4. At the top of the list of checkboxes in the Advanced settings group, ensure Always show icons, never thumbnails is unchecked.
  5. If it's already unchecked, try checking it, clicking Apply, unchecking it again, and clicking OK. Otherwise, just uncheck it and click OK.

Issue 4: AppX packages need to be reinstalled

  1. Open PowerShell as an administrator.
  2. Run:
Get-AppxPackage -AllUsers | ForEach-Object {if ($_.InstallLocation) {Add-AppxPackage -DisableDevelopmentMode -Register "$($_.InstallLocation)\AppXManifest.xml" -Verbose}}

Issue 5: Windows Settings Sync

I've heard that Windows Settings Sync has caused issues with icons for some people. I haven't been able to reproduce this, but you can check whether it's the issue by disabling it temporarily. It's likely that there's either some underlying setting that's the true culprit; it may be resulting in bad icons being uploaded. Reportedly, this primarily affects search results in Cortana and the Start menu.

  1. Open Settings.
  2. Click Accounts.
  3. Click Sync your settings.
  4. Turn off Sync settings.
  5. Go to https://onedrive.live.com/win8personalsettingsprivacy.
  6. Click the Remove button.
  7. Go to https://account.microsoft.com/privacy/activity-history?view=usage. You should see a list of apps you've used recently.
  8. Click Clear activity.
  9. Reboot, just to be safe.
  10. Try re-enabling Sync your settings.

Issue 6: Bad icons/thumbnails are cached

  1. Run Disk Cleanup. (You can search for it in the Start menu.)
  2. Check Thumbnails. Uncheck everything else. If this works, you can stop.
  3. Click OK.
  4. Open the command prompt.
  5. Attempt an automated icon cache clear: ie4uinit -show (prior to Windows 10: ie4uinit -ClearIconCache). If this works, you can stop.
  6. Kill File Explorer: taskkill /im explorer.exe /f
  7. Delete a cache: del /f /q "%LocalAppData%\IconCache.db"
  8. Delete more caches: del /f /q "%LocalAppData%\Microsoft\Windows\Explorer\iconcache_*.db"
  9. If thumbnails were also problematic, delete those caches, too:: del /f /q "%LocalAppData%\Microsoft\Windows\Explorer\thumbcache_*.db"
  10. Start File Explorer back up: explorer

Issue 7: Low disk space

Unsurprisingly, if your drive is almost full, File Explorer will have issues saving thumbnails and will be rather unhappy about it. The solution here is to clear some space. Simple enough.

Issue 8: Windows is borked, proceed to panic

Anytime someone mentions this problem on Microsoft Answers, a Microsoft rep always recommends the same solution. I've never heard of it working for anyone, but it can't hurt to try. (Besides, if you contact Microsoft, they're going to tell you to do it anyway.) It could theoretically fix certain obscure issues.

  1. Open Command Prompt as an administrator.
  2. Run: sfc /scannow. Look for any violations that could be related to the issue at hand.
  3. Run: dism /online /cleanup-image /restorehealth
  4. Restart the computer.
  5. If this actually fixed anything, please be sure to leave a comment.
  • 2
    Nice explanation regarding the PNG files. Issue #1 fixed it for me :) I'll just comment that toggling the display resolution and/or scaling did the final trick for me - even though I already followed #6. – Jeremy J Wong May 19 '18 at 13:07
  • 1
    Hats off to you Sir, you saved my day. That was #1, google's stuff too. The class id was "{9EE0C242-8973-456D-B382-0752476703FD}" which pointed to "C:\Program Files\Google\Drive File Stream\25.196.245.2031\drivefsext.dll" which didn't even existed any more on my machine... upgraded to a newer version it seems. – Simon Mourier May 22 '18 at 7:55
  • 3
    @Zenexer I've just toggled resolution again, and all icons seem to be back. What a strange issue. Thanks again for posting such a thorough answer! – Nathan Upchurch Jun 29 '18 at 16:20
  • 1
    You should also check HKEY_CURRENT_USER\Software\Classes\.png\shellex for {E357FCCD-A995-4576-B01F-234630154E96} (w/o elevating privileges), since the rogue png handler may be present there as well. Removing that entry and restarting explorer process brought the icons back. – Roman Oct 7 '18 at 23:08
  • 2
    I found that Google Drive File Stream seemed to be replacing the registry key regularly. The only fix may be to uninstall GDFS. – X-Cubed Jan 4 at 0:28
1

For years I have faced this issue myself since the early days of Windows 10. Actually, after doing a lot of research, I figured out the main culprit of this issue and it was Google Drive File Stream which I have been using since it has been launched.

While doing my research the only solution to this issue I saw was Uninstalling Google Drive File Stream (GDFS). But as I heavily use that program on a daily basis, I simply couldn't uninstall it. So, I looked for a solution where I can use GDFS and can also fix this broken icon issue. Finally, I saw this Reddit post and once I applied it, all the problem got resolved. So, today in this answer I will show you how you can fix the broken UWP icon on Windows Search issue while keeping GDFS installed.

  1. Run: regedt32.exe
  2. Navigate to: HKEY_CLASSES_ROOT\.png
  3. Look for a ShellEx key with at least one subkey. If you see any subkeys, you've probably found the culprit.
  4. Delete the subkeys.
  5. Right click on the shellex and click on permissions (Screenshots are given below)
  6. Under Groups or user names scroll down and select Administrators
  7. Under the permission section Deny for both Full Control and Read. Then click Apply and Ok.
  8. Restart your PC and if you have more than one monitor attached to your system, turn off the power of them. Only keep one monitor active.
  9. Once the PC restarts, in the windows, search type change resolution and the select the change resolution settings. It will take you to the appropriate settings page.
  10. On the settings page, under Scale and layout change your scale from 100% (or whatever is recommended on your system) to 125% (or higher/lower value than your recommended one).
  11. Once you change the scale, click on the search box again and search for UWP apps whose icons were broken before. You should see the icons are back to their normal state. If you don't see that, again change the scale back to 100% and again increase it to 125%. Do it a couple of times as in some cases, it takes more than one try to make it happen. Every time you change the scale, go to search and check if the issue has been resolved or not. As soon as you see the issue is resolved, change the scale back to 100% or whatever was your recommended scale.

🎉 Problem Solved!!! 🎉


🛑 Some Special Note & Disclaimer

Though the above solution will fix the broken UWP icon issue while keeping Google Drive File Stream (GDFS) installed, but it will also bring a minor annoying issue. After this fix, you might see your computer is getting refreshed (as if you are pressing F5) randomly. Though this will not create any issue where you can't do your work or something. But if you minimize everything in your desktop and keep looking at the screen with icons, you will definitely notice it.

Again, this is not going to slow down your system or hamper your work, but as I have seen it, I thought it is best to give this disclaimer. Currently, there is no way to fix this automatic refreshing issue or at least I am not aware of it. If anyone who is reading this answer come up with a solution to fix the refreshing issue, do let me know, I will update the answer.

I've also sent feedback to Google regarding this issue, but I guess many other people have also done it and as they haven't fixed the problem yet, I'm not sure if they will ever do. But the best fix for this issue is something only Google can push.


📸 Screenshots of the above-mentioned steps

Right click on shellx and go to permissions Denying all permission for Administrator Changing screen resolution Screen resolution change page

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.