1

Whenever I copy a line or a word at the end of a line and then paste, it includes a newline.

Is there anyway to prevent this behavior? I don't want it to copy or paste the newline.

2

End your selection at the end of the word, not the end of the line.

The newline character gets selected as any other character would. The trailing space in a selection indicates the selection includes the newline.

To see the difference, "show paragraph marks and other hidden formatting symbols" by either clicking the toolbar button on the Home ribbon (Paragraph section) or press Ctrl+*.

I often find it quicker to make the selection with the mouse. If I see the extra space at the end of the selection, I press Shift+Left Arrow to shorten the selection by one character: the newline.

Note: You may have some success modifying the following "Editing options" under File (menu), Options, Advanced (left sidebar section):

  • When selecting, automatically select entire word
  • Use smart paragraph selection
  • Use smart cursoring
  • Is there anyway to prevent Word from automatically including the new-line? – IMTheNachoMan May 3 '18 at 17:29
  • The editing options may help (see edited answer). In summary, just make sure the selection doesn't include the trailing space. – Steven May 3 '18 at 19:42
  • I've turned those options off. And the goal is to simplify the process of copy and pasting. I want to be able to just double click on a word, even if its at the end, and copy and paste. Having to modify the selection after double clicking is a pain. :/ – IMTheNachoMan May 4 '18 at 4:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.