0

I have a notebook that came with Windows 8.1, but formatted the HDD and installed Linux to a 64GB partition after a failed Windows 10 upgrade. Now, I want to dualboot Windows 8.1 with Linux. I selected USB in the Boot Device Menu, but I get a error that reads:

The selected boot device failed. Press ENTER to continue.

It happens on both Legacy and UEFI mode.

I tried made the installer bootable by:

  1. Using Disk Image Writer on Linux (did not show up in Boot Menu afterwards).
  2. Creating a NTFS partition, copying all the files from the ISO into it, and adding a Bootable flag. (caused "Boot device failed).

I know the ISO works because it booted from it in a virtual machine.

How do I get the Windows 8.1 installer to boot?

  • What format is the USB stick, and what software/procedure did you use to make it bootable? – ViRALiC May 3 '18 at 17:22
  • @ViRALiC I tried Disk Image Writer on Linux and manually making a bootable USB (more detail added in the question). – Zackary May 3 '18 at 17:29
  • You can't make any usable Windows installation media from Linux nowadays, except when using MKUSB. If you have access to a Windows PC just do it there with the official tool. – user772515 May 8 '18 at 14:03
0

The problem, as stated by @user772515, was the boot tool I was using.

UNetbootin and Disk Image Writer in Linux wouldn't make a bootable USB, so I used Rufus (for Windows) to create one.

It only booted in BIOS compatibility mode (I might have selected NTFS instead of FAT32), but the Windows 8.1 USB would finally boot and install.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.