0

Config: VirtualBox VM w/Server Essentials 2016 (bridged wifi adapter, promiscuous all, static IP 192.168.1.200), running on Win10 Pro host static IP 192.168.1.10. Other laptops on same AP/subnet, Win10 Pro static IPs 192.168.1.11-14

Wifi AP 192.168.1.1, running DD-WRT

Situation: Did a vanilla install of Server 2016, set static IP before configuring server, and disabled Windows Firewall. I am able to perform any network function I can think of from the DC to other network machines (ping, access shares, internet) but am unable to see the DC from any machine other than the VM host. I tried joining some of the machines to the domain the old way and using the connect app but same result except for the host machine. Curiosity inbound: on my AP web config, if I simply click "Apply Changes" whether I make any or not, I get one or two good pings from my laptops to the DC as the router soft boots, then back to "Request timed out". This leads me to believe it's something I can resolve within the router.

I tried setting my laptop adapters to use the DC as DNS but it did not change the situation. Right now all machines are using the AP as the DNS and I'm not sure why the host works but others do not. I generally feel like I can fumble my way around a network but this time I feel stuck. Any input is appreciated, thanks.

  • "unable to see" is vague to the extreme. Unable to ping? Unable to discover via NetBIOS etc.? Unable to access SMB filesharing service? Unable to access LDAP directory service? If the server literally became invisible to the webcams of your other computers, it might be a vampire. – grawity May 4 '18 at 4:51
  • Also, since you said VirtualBox's "Wi-Fi bridging" is involved, can you check whether other hosts can successfully resolve the IP address via ARP? (Using Wireshark, for example.) This is very likely to fail, due to the way VirtualBox has to emulate "bridging" over otherwise-unbridgeable Wi-Fi. – grawity May 4 '18 at 4:53
  • gravity, when I say it's not seen, I mean via any means I can think of. Can't ping, browse, nothing except that quick ping reply when resetting the router. I'll study up on using ARP so I can give it a shot when I get back home, appreciate the idea. – kornesque May 4 '18 at 10:49
  • Besides VirtualBox's trickery, it might also be that your router's WiFi AP does ARP-proxying on behalf of wireless clients (this is common) but doesn't quite understand that your client can have multiple IPs behind it (host and VMs). In either case, Wireshark/tcpdump often reveals this. – grawity May 4 '18 at 12:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.