2

While performing the steps to install a GNOME desktop on Centos 7, I am getting the errors as follows

[root@test-vm-2 ansible]# yum -y install xrdp xorg-x11-xinit
Loaded plugins: fastestmirror, langpacks
Loading mirror speeds from cached hostfile
 * epel: ftp.nluug.nl
Package xorg-x11-xinit-1.3.4-1.el7.x86_64 already installed and latest version
Resolving Dependencies
--> Running transaction check
---> Package xrdp.x86_64 1:0.9.6-1.el7 will be installed
--> Processing Dependency: xorgxrdp for package: 1:xrdp-0.9.6-1.el7.x86_64
--> Running transaction check
---> Package xorgxrdp.x86_64 0:0.2.6-2.el7 will be installed
--> Processing Dependency: xorg-x11-server-Xorg(x86-64) = 1.19.5 for package: xorgxrdp-0.2.6-2.el7.x86_64
--> Finished Dependency Resolution
Error: Package: xorgxrdp-0.2.6-2.el7.x86_64 (epel)
           Requires: xorg-x11-server-Xorg(x86-64) = 1.19.5
           Installed: xorg-x11-server-Xorg-1.19.3-11.el7_4.2.x86_64 (@updates)
               xorg-x11-server-Xorg(x86-64) = 1.19.3-11.el7_4.2
           Available: xorg-x11-server-Xorg-1.19.3-11.el7.x86_64 (base)
               xorg-x11-server-Xorg(x86-64) = 1.19.3-11.el7
           Available: xorg-x11-server-Xorg-1.19.3-11.el7_4.1.x86_64 (updates)
               xorg-x11-server-Xorg(x86-64) = 1.19.3-11.el7_4.1
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

The steps I tried to install

yum -y install epel-release
yum -y groupinstall "GNOME Desktop" "Server with GUI"
yum -y install xrdp xorg-x11-xinit

This has started to happen since today. I was able to install the XRDP component till yesterday. Please help me in resolving the issue.

I am using the Openlogic Centos 7.4 image on MS Azure.

2

There's a known bug. See: https://bugzilla.redhat.com/show_bug.cgi?id=1565957

They note:

Using EPEL with older point releases is not supported. You need to upgrade to the latest (7.5) or manually install older xorgxrdp package.

The bugzilla thread notes you can manually install xorgxrdp-0.2.6-1.el7. Then you will be able to yum install xrdp. You can get xorgxrdp-0.2.6-1.el7 from https://koji.fedoraproject.org/koji/buildinfo?buildID=1062201 . These commands should work:

$ yum install https://kojipkgs.fedoraproject.org//packages/xorgxrdp/0.2.6/1.el7/x86_64/xorgxrdp-0.2.6-1.el7.x86_64.rpm

$ yum install xrdp

0

Just read error message: You could try using --skip-broken to work around the problem

I'm using

yum update --skip-broken

  • Yes. But this wont install xrdp. I had already tried this option – sibh8 May 17 '18 at 7:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.