0

I've setup Host-Only Network for my VirtualBox v5.2.8 r121009 Guest (Running Windows 10 Enterprise) where the Guest will act as a DHCP Server (using Open DHCP Server) so that the Windows 7 Host (my laptop), will obtain an IP address from the Windows 10 Guest. However, it did not work.

I set the Network Adapter on my Windows 10 Guest to 192.168.88.1. This is successful and reflected on ipconfig.

Windows IP Configuration


Ethernet adapter Ethernet:

   Connection-specific DNS Suffix  . :
   Link-local IPv6 Address . . . . . : fe80::ad9b:f469:78eb:14bc%3
   IPv4 Address. . . . . . . . . . . : 192.168.88.1
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Default Gateway . . . . . . . . . :

Open DHCP Server also successfully detects the fixed IP address.

[04-May-18 23:57:46] Open DHCP Server Version 1.50 Windows Build 1027 Starting..
[04-May-18 23:57:46] Starting DHCP Service
[04-May-18 23:57:46] Logging: All
[04-May-18 23:57:46] DHCP Range: 192.168.88.1-192.168.88.254/255.255.255.0
[04-May-18 23:57:46] Server Name: DESKTOP-4DURJST
[04-May-18 23:57:46] Detecting Static Interfaces..
[04-May-18 23:57:46] Lease Status URL: http://127.0.0.1:6789
[04-May-18 23:57:46] Listening On: 192.168.88.1
[04-May-18 23:57:46] Network changed, re-detecting Static Interfaces..
[04-May-18 23:57:46] Lease Status URL: http://127.0.0.1:6789
[04-May-18 23:57:46] Listening On: 192.168.88.1

On the Windows 7 Host, I set the "VirtualBox Host-Only Network Adapter" to "Obtain an IP address automatically" and then disabled and re-enabled the adapter. However, the "VirtualBox Host-Only Network Adapter" is unable to get the IP address from my Windows 10 DHCP Server. I've used Open DHCP Server on physical PCs and networks, and it works using the same configuration, but I'm unable to get it to work in a virtual environment.

Ethernet adapter VirtualBox Host-Only Network:

   Connection-specific DNS Suffix  . :
   Link-local IPv6 Address . . . . . : fe80::ac22:8db7:ba64:fb12%28
   Autoconfiguration IPv4 Address. . : 169.254.251.18
   Subnet Mask . . . . . . . . . . . : 255.255.0.0
   Default Gateway . . . . . . . . . :

Note: The DHCP Server for "VirtualBox Host-Only Network Adapter" is disabled.

migrated from serverfault.com May 4 '18 at 18:10

This question came from our site for system and network administrators.

1

The problem was resolved after I rebooted the host! Apparently, rebooting the Guest don't work as I've done that many times.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.