1

It seems to be a well known problem that bluesceens with message

DRIVER_IRQL_NOT_LESS_OR_EQUAL

are caused by touchpad drivers SynTP.sys und HKKbdFltr.sys. As I do not need the touchpad anyways (I use a mouse) I want to disable it, but it seems to be impossible.

It happens while working or gaming if I accidently touch the touchpad for whatever reasons.

Here is what I have tried to get rid of this:

a) Update the touchpad drivers to the newest version

Did not help anything - the touchpad keeps causing bluescreen at least if a mouse is connected.

b) Disabling the touchpad in the Windows touchpad settings

Obviously impossible - look at the screenshot:

Touchpad disable not available in Windows 10

c) Disabling the touchpad via the device manager

Disabling touchpad via device manager

Most devices can be deactivated or uninstalled on my notebook, but not the touchpad. You can only uninstall it.

I uninstalled:

  • Synaptics WBDI Fingerprint Reader
  • Insyde Airplane Mode HDI Mini-Driver
  • Synaptics SMBus Touchpad

As I think those drivers are touchpad related. I restarted my notebook and Windows automatically installs those again.

It seems like it is impossible to get rid of my problem causing touchpad that I do not need. Any help would be appreciated.

3
+50

There are many posts to be found of people having the same problem and many solutions, some of which I have listed below.

I can see that you have the option to uninstall the device. The problem is that it will reinstall itself on the next reboot. An idea for preventing the reinstallation of the device might be to follow the instructions on this answer to block Windows Update from updating the Synaptics device.

Another option you should disable (if you have it) is in PC Settings, under Devices, Touchpad. Disable the touchpad and clear the "Leave touchpad on when a mouse is connected" option.

It might also help to go to Control Panel, Hardware and Sound, Devices and Printers, Mouse. On the "Device Settings" tab, clear the option "Disable internal pointing device when external USB pointing device is attached" (again, if you have it).

On some Dell laptops, the setting to disable the touchpad is located in the Dell's support software : Open the Touchpad application in Dell Pointing Devices, select the mouse and check the option for "Disable Touchpad when USB Mouse present option".

A regedit answer advises to go to the key HKEY_LOCAL_MACHINE\SOFTWARE\Synaptics\SynTP\Defaults, and set the value of all string entries of the form PalmKms…, to 0. These values determine the amount of ms that the touchpad stays disabled after keyboard input has been detected.

Another answer also advises in HKEY_LOCAL_MACHINE\SOFTWARE\Synaptics\SynTPCpl to set the value of RestoreAllDefaults to 0, and in Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Synaptics\SynTP\Install the value of Delete User Settings to 0, and restart the computer.

Still another answer advises downloading and installing an older driver from here. This apparently destroys the touchpad in some unclear manner.

  • Ok thanks a lot. I think there are like two-three possibiliities I did not try yet. I will accept if anything works and let you know (Notebook is a custom gaming notebook from XMG therefore manufacturer specific solutions probably are not known). – Blackbam May 15 '18 at 11:36

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.