Ever since Microsoft released Windows 8 and then Windows 10, Intel stopped releasing new drivers for their USB 3.0 ports integrated into their newer chipsets. They let Microsoft do the work. I have a Z270 motherboard and the Intel(R) USB 3.0 eXtensive Host Controller is currently removable.

USB 3.0 ports removable?

From the Device Manager, the problematic drivers:

Intel Host Controller

Computer Management

Windows Update does say I have the latest driver. With Intel not releasing any new driver, what are my options to make those ports non-removable in Windows 10, considering I obviously can't remove them without going into my BIOS settings?

  • Comments are not for extended discussion; this conversation has been moved to chat. – DavidPostill May 10 at 17:47
  • 1
    Despite this not being in any direct way related to ReactOS, I would recommend that you ask this question on the ReactOS forums and/or ReactOS IRC channel(s), as ReactOS is being built by people who are literally reverse engineering MS Windows from the ground up, and they may have some insight regarding what causes Windows to show a USB device as removable. In particular, there's a person there known as vgal who has been working on some major updates to ReactOS' USB stack(s) and might be able to shed some light on your issue. – 3D1T0R May 14 at 3:14

This is not a driver problem of the eXtensible Host Controller device : I have exactly the same device and with exactly the same installed driver, but the device does not show up as removable.

The problem might be a remnant from some past installation on your computer, perhaps from when Windows was upgraded to Windows 10.

I suggest the old method of deleting the device in Device Manager and reboot, to reinitialize the device to a clean state.

Otherwise, there have been reports about such problems being solved by a clean install of Windows. But if your device is functioning correctly, I do not think that the problem warrants such a drastic solution.

  • Windows 10 was freshly installed a day or two before I made this post. – dnLL May 10 at 14:10
  • This might be a problem with some other part of Windows, not with the eXtensible Host Controller. Why did you re-install Windows, did you take a backup first, and did everything work fine before? – harrymc May 10 at 14:42
  • I changed my SSD and haven't reinstalled for over a year, I just decided it was time for a good clean-up. I don't recall having that problem before reinstalling. – dnLL May 10 at 16:33
  • Do you still have the old installation? Can you restore it? – harrymc May 10 at 16:43
  • 1
    I have encountered the same mistake countless times on this forum : reformatting the disk and trusting the Windows installation to correctly configure the new setup. The same precautions must also be taken before any major Windows upgrade : Taking an image backup of the system and exporting all drivers. I repeat my advice of doing nothing if the device functions correctly. Further modifying of your setup and installing more drivers might only make things worst. – harrymc May 10 at 18:41

Please try the modded Intel USB drivers from Win-RAID.

Don't forget to import certificate with ".\Certificate\ImportCertificate.cmd" and install with ".\DPInst64.exe".

As there is a feedback that it worked for B250 in Windows 10 1709 x64, it should also work for Z270, which has the same USB3 controller.

  • I won't have time to try it before the bounty ends as I've been doing 16h shifts at work ever since I posted so I'll just give you the bounty considering you've made a lot of efforts to help me resolve this. I will let you know as soon as I can try all of this. – dnLL May 15 at 4:19

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.