After replacing the default Windows task manager with Sysinternals’ process explorer via the Options → Replace task manager menu, how do you undo that action, i.e. restore the original task manager? I’ve already tried clicking that menu again, but it doesn’t do anything.


Delete the subkey Debugger of the registry key HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Image File Execution Options\taskmgr.exe.

In cmd, you can accomplish this by running (as admin): reg delete "HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Image File Execution Options\taskmgr.exe" /v Debugger.

  • 8
    the answer is almost perfect, just add that you need to run cmd as admin
    – kaosmos
    Jan 29 '19 at 20:11
  • 3
    According to the help documentation it's meant to change to "Restore Task Manager" but there must be a bug which doesn't correctly detect which state its in. Jul 3 '20 at 1:23
  • Don't delete the whole key, just delete the Debugger string value. Sep 23 '20 at 11:08
  • Yes, this worked fine in v16.12. It was not a "Restore Task Manager" but it had a checkmark like the other entries and was uncheckable. Now with new Laptop I installed lates v16.32 and there the menu entry does not behave correctly anymore. :-(
    – Vampire
    May 10 '21 at 21:41
  • Actually it is a bug in the 64-bit version. Starting the 32-bit version the menu entry behaves as it should, so you can use the 32-bit version to first make it the default and then restore the vanilla one. I guess there is some string comparison that does not consider the changed name for the 64-bit executable.
    – Vampire
    May 10 '21 at 21:46

maybe they fixed that in the latest versions?

ugh another post in microsoft forums suggests to

  1. run procexp.exe (the 32-bit version, not procexp64.exe), choose Options -> Replace Task Manager there
  2. close it
  3. call task manager, so the 32-bit procexp is opened, and go to Options -> Restore Task Manager.

I am on Windows 10 Now I didn't see that happen, 32-bit procexp still writes "Replace Task Manager" But if I open procexp.exe as Administrator there is a tick sign instead of a Shield sign next to Replace Task Manager -> I press on the tick sign, the tick goes away.

I tried to do the above with 64-bit version and it worked too - it's just that instead of a tick sign there's always a shield.

oh whatever.

  • manually opening procexp.exe worked for me as described
    – Chris
    May 11 '21 at 7:33

We can accomplish this using PowerShell:

# Restore taskmgr.exe as Task Manager
Remove-ItemProperty -Path "HKLM:\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Image File Execution Options\taskmgr.exe\" -Name 'Debugger' 

# Check if PROCEXP64.EXE is still Task Manager
if($null -eq (Get-ItemProperty  -Path "HKLM:\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Image File Execution Options\taskmgr.exe\" | Select-Object -ExpandProperty 'Debugger' -ErrorAction Stop)) { 
    Write-Host "taskmgr.exe successfully restored as Task Manager"

Not the answer you're looking for? Browse other questions tagged or ask your own question.