4

Sometimes when I bump my mouse or my keyboard my computer turns on. How do I prevent that?

7

You can disable all devices from waking your computer with powershell -Command "powercfg /devicequery wake_armed | ForEach{ powercfg /devicedisablewake $_ }".

In cmd, you can run powercfg /devicequery wake_armed to get a list of the devices that are currently allowed to wake up your computer. Chances are you’ll see a couple HIDs (human interface device) and maybe a network card. You can copy/paste these into the corresponding command, powercfg /devicedisablewake "your device here", but that’s annoying.

The ForEach{ $_ } operates a bit like xargs if you’re familiar with that, where $_ is a placeholder for the text in each line of the input (i.e. the powercfg /devicequery wake_armed before the pipe).

| improve this answer | |
0

When you want to disable it only for the mouse and keyboard do this:

  1. Open the Device Manager
  2. Navigate to Keyboards
  3. Select and default/ using keyboard (usually Standard PS/2 Keyboard), right-click and go to properties
  4. Tap Power-Management and uncheck “Allow this device to wake the computer”: enter image description here

Same steps for the mouse!

Note: This does not work on every device, on laptops there maybe you have to go to the Power Options!

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.