-1

I have two computers, say A and B, both running Windows 10 , build 1709,and having :

  • current User only in Local group "users"
  • with Local Administrator Account : enabled
  • UAC : Enabled
  • Printer Sharing : Enabled

I have tried my best to kept both computers identical as much as I can. I want to run a program on both machines locally (no remote execution) with administrator rights and elevated.

On Computer A

Programs are running with elevated privileges, NO UAC message.

On Computer B

It shows some kinds of errors and UAC messages, for which I tried,

  • Running program with psexec

    psexec.exe -i -u administrator -p "password" -accepteula path\program.exe
    

    That exits out showing error :

    ERROR : "this operation need an elevation"
    (original message : "L'opération demandée nécessite une élévation.")  
    
  • Running program with Runas

    runas /noprofile /user:administrator path\program.exe
    

    That exits out showing error :

    ERROR : "740 : this operation need an elevation"
    (original message : "740 : L’opération demandée nécessite une élévation.")  
    
  • Using cmd.exe to launch program

    psexec.exe -i -u administrator -p "password" -accepteula cmd.exe /C start "xxxx" path\program.exe
    

    In this case, program is running as Administrator but privileges are still not elevated.

  • Now In the Running program,

    • I have to give it admin rights (elevated privileges) using compatibility tab.
    • After which program finally runs with elevated privileges but I got an UAC message.
    • So, I disabled UAC for Administrator account and Now, It runs with elevated privileges and no UAC message.

This problem is not specific to this program only, rather other applications ( such as Bitdefender, Anti-Ransomware, Fraps, Paint-Shop pro 6 ) are also showing it.

And None of this happens on Computer A.

Also, psexec options like -h or -s has never worked for me, neither on computer A. It shows an error on starting service. So on computer B, I have to :

  1. Launch it with cmd.exe
  2. Use compatibility,
  3. Disable UAC for administrator

I don't want to use compatibility and want to maintain UAC enabled, What I need to do to make computer B act like computer A. Basically doesn't show these UAC errors ?

So what could be the exact root cause and the solution for it ?

closed as too broad by Ramhound, Anaksunaman, n8te, Pimp Juice IT, G-Man May 17 '18 at 3:43

Please edit the question to limit it to a specific problem with enough detail to identify an adequate answer. Avoid asking multiple distinct questions at once. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

  • AS i write, i'm only a normal user (belonging only in users local group), I'm not the built-in Administrator, i'm not an administrator user or either a power user. I disabled UAC messages in control panel, users account, UAC settings. – user34224 May 8 '18 at 15:52
  • secpol.msc settings are differents on A and B. Making all default everywhere and rebooting. I will tell. – user34224 May 8 '18 at 23:45
  • There are a lot of UAC settings in secpol.msc. And i don't understand all of them. How is there differences on computer A and B from the default settings ? i don't know beause it's personnal computers and i never use mmc. So finaly the key was to restore default values in secpol.msc/local strategies/security options. Psexec and runas are working. Make an answer so i can accept it. – user34224 May 9 '18 at 1:35
0

Psexec and runas didn't work properly because of UAC settings.
I used secpol.msc to see what default settings have been altered and restore them.
UAC settings are in local strategies / security options.

Not the answer you're looking for? Browse other questions tagged or ask your own question.