6

I have a weird problem with my Windows 10 Pro setup. I want to install Ubuntu bash from the Microsoft store but whenever I click on get/install in the store nothing happens. Working message briefly appears and the store windows kind of reloads and the button goes back to get/install. Any ideas? I tried resetting the store cache and enabling Linux Subsystem through power shell all without luck. Same thing happens when I tried installing anything from MS store. My system has all up to date updates and it's pretty much brand new as I have only just unboxed this laptop.

Update: build number 1803.

2

I was having the same issue. I uninstalled WSL, rebooted, reinstalled WSL, rebooted. Then I opened the Windows Store, logged out, logged back in, and was able to install.

  • I was able to resolve this same issue in a similar way - by rebooting my PC, then signing out of the Windows Store app, then signing back in. – Matthew King May 9 '18 at 10:14
5

What I did to resolve this issue was simply logging out of and then back into the Windows Store App. I'm running Windows 10 x64 build 1803.

  • 1
    That's probably also a valid solution for most. Can't verify it now mu issue has been resolved but it makes sense. It's clearly some post update store issue. – EmojiJesus May 10 '18 at 5:33
  • TL;TR: This should be marked as answer to this question. I can confirm simply logging out and back in to Microsoft Store solves the problem. I have verified this procedure on two computers with Windows 10 x64 1803. No need to reinstall WSL. – mloskot May 11 '18 at 11:06
  • This should be the first thing to try, before reinstalling or restoring anything! – sdive May 11 '18 at 14:48
  • @mloskot - We have a case of duplicate answers being submitted a short amount of time between one another. The author of the question is the sole person who decides which answer should be accepted. – Ramhound May 15 '18 at 12:42
  • @Ramhound Understood. I just made a suggestion. – mloskot May 16 '18 at 13:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.