1

I created my YUMI USB flash drive some time ago. I’ve used this drive to boot various PC’s successfully (so other situation than in an existing question).

However, when I tried to boot my laptop using the flash drive today, I got a single message:

Boot error

I was then able to reboot the computer using CtrlAltDel.

I’ve been also using the same drive to transfer data since a YUMI drive is just a bootable FAT32 drive. So I’m not sure it hasn’t got unbootable somehow. In the Disk Management in Windows 7, the drive is shown as Healthy (Active, Primary Partition).

I tried to add another Linux distro to the drive using YUMI-2.0.5.6.exe on Windows 7 (the same machine I had used to create the drive) and was hoping it could repair the bootloader but the next boot was the same. The first log message of the installer was Good Syslinux exists, so it most likely did not touch the bootloader.

Is there any way to repair the bootloader of existing YUMI drive? I haven’t found any corresponding option in the install window.

install window screenshot

1

I was able to force YUMI to reinstall the bootloader by renaming the following files in the multiboot folder:

  • libcom32.c32
  • ldlinux.sys (hidden by default)

Then YUMI reinstalled bootloader when installing another ISO using its wizard. The file ldlinux.sys was recreated but libcom32.c32 not, so I had to rename it back. Then I was able to boot my YUMI drive again!

The described behavior is based on the following YUMI source code:

${IfNot} ${FileExists} "$BootDir\multiboot\libcom32.c32" 
${AndIf} ${FileExists} "$BootDir\multiboot\ldlinux.sys"
MessageBox MB_ICONEXCLAMATION|MB_OK $(WarningSyslinuxOLD)
Quit
${EndIf}

IfFileExists "$BootDir\multiboot\libcom32.c32" SkipSyslinux CreateSyslinux ; checking for newer syslinux

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.