0

I am trying to run dual configuration on my PC. I have Windows 10 installed on SSD and I installed Linux on HDD. When Installing Linux Ubuntu I created boot partition which is visible by Windows (disk 0 is Windows and disk 3 is Linux):

enter image description here

I used easyBCD to add entry to Windows BootManager, however after adding it and choosing this option in booting I enter GRUB4DOS screen: "[ Minimal BASH-like line editing is supported. For the first word, TAB lists possible command completions. Anywhere else TAB lists the possible completions of a device/filename. ] grub> " I am unable to write anything there and Linux doesn't start. How can I properly configure Windows 10 bootmanager (or how to install properly linux so GRUB executes) to be able to boot both Linux and Windows?

I have UEFI BIOS so I had problems to have GRUB as main bootmanager but CSM is set to legacy. I installed Linux as in this answer.

  • I installed Linux as in this answer and yet you did the opposite of what the good answers are saying? Do not install in Legacy mode especially when the other OS (Windows) is installed in a different mode (UEFI mode). Please take the time to understand how UEFI works and how to dual-boot in such mode: askubuntu.com/questions/221835/… PS - EasyBCD is NOT for UEFI systems, stop using it or you'll risk Windows not booting. – user772515 May 9 '18 at 18:42
  • So you're booting GRUB with Windows Boot Manager? I can only imagine what the problem is. There's a whole host of issues with this that could keep it from booting. I actually disagree with MichaelBay here in that you should leave CSM on. Windows appears to be installed legacy so thats water over the dam. You should install Ubuntu in UEFI. Your mobo might give you a hard time about it but you need to boot the installer with an option that says "UEFI: Ubuntu.." or something like that. The reason its not working is because Windows boots in legacy mode and then chainloads GRUB which expects UEFI. – jdwolf May 10 '18 at 1:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.