9

I have noticed that all my taskbar and start menu jump lists are broken. They are broken in a very specific way:

  • The items show up, but clicking them does nothing (clicking dismisses the jump list, but does not open the corresponding app)
  • None of the items show a context menu when right-clicked (an empty gray box appears, as if an empty context menu appeared)
  • Jump lists and the context menus work in safe mode

My problem is very similar (if not identical) to the one described in Windows 10 Taskbar JumpList Issue, Not working and in Taskbar > File Explorer > Context Menu failing me and in the related Reddit post and in the related forum post. However, I have more information on the potential cause and more attempted solutions.

There are also two related posts on Microsoft Answers: related post on Microsoft Answers and the other related post, but none of the solutions worked for me (or for the original posters).

I noticed this in Anniversary Update, after updating Visual Studio. Then, I updated to April Update, which fixed the issue. Now, I updated Visual Studio (from 15.6 to 15.7) and it is broken again. The jump lists are broken on both the taskbar and start menu, and they are broken for all apps (both desktop and store).

Things I tried:

  • Deleting all files from the AutomaticDestinations directory
  • Deleting some files from the AutomaticDestinations directory
  • Resetting jump lists from settings
  • Reinstalling all Store apps with a PowerShell script
  • Running sfc /scannow
  • Running dism with restore health option
  • Pinning items
  • Restarting the computer
  • Restarting in safe mode and then restarting again
  • Disabling Internet Explorer
  • Using the Start Menu troubleshooter: It finds corruptions, but does not apply a fix
  • Copying TileDataLayer folder from different computers and then repairing
  • Creating a new user account (this also does not work)
  • Repairing Visual Studio (it just made Visual Studio slower)
  • Restoring the original AppData folder location and creating a junction point to it from the other partition
  • Removing all junction points related to Visual Studio
  • Completely removing all versions of Visual Studio and fresh installing Visual Studio 2017
  • Installing April Update
  • Installing October Update
  • Using the ShellExView to disable all shell extensions with Context Menu flag and all shell extensions whose File Created time and CLSID Modified Time was after the problems started occurring
  • Running the recommended script Get-AppXPackage -AllUsers | Foreach {Add-AppxPackage -DisableDevelopmentMode -Register "$($_.InstallLocation)\AppXManifest.xml"} which helps fix similar problems
  • Posting an issue on the Visual Studio feedback site and through the Feedback Hub application and waiting for a fix
  • Removing all CD/DVD mounting software
  • Turning jump lists on and off in the Settings
  • Setting the JumpListItems_Maximum in the registry
  • Using msconfig to test different startup configurations (disabling all non-Microsoft services – jump lists do not work, diagnostic startup – jump lists do not work; safe-mode – jump lists work)
  • Disabling OneDrive (both in startup and from Group Policy) – interestingly, the items that are opened from OneDrive do work; but all other items do not (both clicking and the context-menu).
  • Removing all Anti-Virus software

I have some junction points on my C: drive (all in Program Files and ProgramData).

It also seems that Cortana shortcut button (WinKey+C) gets broken whenever jump lists are broken (which is usually within a few days after repair installing Windows 10).

Can anyone provide any clues or suggestions?

Edit 1 (After restoring the default AppData folder)

A peculiar thing happens when accessing the Recent Items folder: when accessed by navigating directly to it in explorer, it does not contain the CustomDestinations and AutomaticDestinations folders, but when accessed by entering the same directory into Run the folders are visible along with many items that do not appear in jump lists.

Edit 2 (After repairing Windows installation)

Even though reupdating system to April Update resolved the problem, the question remains, since the actual cause of the problem is unidentified and I expect it to happen again after another Visual Studio update.

Edit 3 (After a few days)

After about two days of working properly after doing the repair install, my jump lists are not working again. All the history items are shown, but they are again unclickable and the context-menus are empty. Obviously, doing a repair install every few days is not an option. During the few days that the jump lists worked properly, I did not install anything on my system.

Edit 4 (After removing Visual Studio and removing junction points)

After opening Visual Studio 2017 and running a UWP (Microsoft Store) app with a debugger attached, my jump lists were destroyed again.

I decided to remove both Visual Studio 2015 and Visual Studio 2017 and reinstall Visual Studio 2017, remove all junction points I had (I had some junction points for Visual Studio installation), reinstall Visual Studio 2017 and repair install Windows. Removing Visual Studio installations and the junction points did not fix the issue. Repair installing did, as noted in the answer. However, setting up a scheduled task to reinstall Windows ever few days is really not a solution.

Edit 5 (After updating Visual Studio to 15.7.3)

The jump lists are broken again. They have been working for almost a few weeks. After Visual Studio update the jump lists show the same broken behavior.

Edit 6 (After updating Windows 10 to October 2018 Update)

Fixed for five days and then broken again. Possibly related to Visual Studio again. They seem to break when a UWP application is deployed.

Edit 7 (After meddling with startup configuration)

After trying to disable shell extensions, startup items and services, by various means (including msconfig, ShellExView, the Task Manager, the Registry Editor and the Services application), I have concluded that the only state in which the Jump Lists work is safe mode.

Edit 8 (After the insightful answer by Zenithies)

I have realized that I have many 10000, 10001 and 10016 errors in the Event Log. The 10000 and 10001 errors occur after attempting to click on a jump list item. Below are the errors.

Unable to start a DCOM Server: {C82192EE-6CB5-4BC0-9EF0-FB818773790A}.

Unable to start a DCOM Server: {9AA46009-3CE0-458A-A354-715610A075E6} as Unavailable/Unavailable.

The application-specific permission settings do not grant Local Activation permission for the COM Server application with CLSID {2593F8B9-4EAF-457C-B68A-50F6B8EA6B54} and APPID {15C20B67-12E7-4BB6-92BB-7AFF07997402}

After going through the registry, I identified one of these to be the RuntimeBroker component. I proceeded to see the corresponding component service and noticed I had duplicate entries for rundll32.exe and RuntimeBroker components similar to the Runtime DCOM Server appears twice post. When trying to modify permissions I get the following error.

One or more of the permission entries attached to Registry Value has an unrecognized type and can not be displayed.

The jump list issues can be circumvented by manually calling the jump list component. However, the permission issue still exists and the cause is probably one of the Windows updates, considering that the Runtime Broker component service is duplicated and has a different ID.

The related post has more info on this: Unable to start a DCOM Server.

Edit 9 (After updating Windows to 1903 and Visual Studio to 2019)

As with updates before, the lists were fixed for a couple of days.

The lists are now broken again, but now a menu is shown with the text "This item is unavailable" and prompts to delete it from the list. After running the temporary fix script from Edit 8, the problem is resolved until the next shutdown. I've reported this through Feedback Hub, once again.

Edit 10 (After updating Windows to 2004)

Still broken. Every major Windows update seems to disable the Task Scheduler fix. Re-enabling the scheduled script fixes the problem. However, the cause of the problem is not resolved. This is still only circumventing the problem.

10
  • You will need to remove Visual Studio and reinstall it in order to fix this problem. Worth pointing out this honestly sounds like an issue with your configuration, specifically, the junction points you have configured. – Ramhound May 9 '18 at 22:14
  • @Ramhound Are you sure this is a solution? Do you know, from experience, that it is indeed the issue? I really don't want to reinstall Visual Studio if I don't have to. – Igor Ševo May 10 '18 at 17:01
  • If I was not fairly confident, about the reason this problem even happens, I wouldn't have suggested it that solution. However, I don't believe in submitting single sentences as an answer, to any question especially to a problem that is as nuanced as this one. – Ramhound May 10 '18 at 17:16
  • Repairing did not work. – Igor Ševo May 13 '18 at 15:41
  • Can you try to undo the junction point on AppData/Roaming ? And which ones have you created in Program Files? – harrymc May 13 '18 at 18:59
2

Another workaround worth trying:

Checking the possible cause of trouble:

  • Click random jump list item that does not work a few times.
  • Run Event Viewer (ie: WinKey+R -> eventvwr.msc)
  • Check section Windows Logs -> System
  • If you can see bunch of errors with DistributedCOM source and ID 10000 and error message that reads as: Unable to start a DCOM Server: {C82192EE-6CB5-4BC0-9EF0-FB818773790A}, please continue:

Running JumpViewerExecuteHelper manually

  • WinKey+R
  • run: %SystemRoot%\System32\rundll32.exe shell32.dll,SHCreateLocalServerRunDll {c82192ee-6cb5-4bc0-9ef0-fb818773790a}
  • If this is root cause of your trouble, UAC will ask you for elevated permissions for rundll32.exe process
  • After confirm, your jump lists should be working. (until restart or logging-off)

If this is the case, you can now create a shortcut:

Adding startup shortcut

  • desktop Right Click->New->Shortcut
  • target: %SystemRoot%\System32\rundll32.exe shell32.dll,SHCreateLocalServerRunDll {c82192ee-6cb5-4bc0-9ef0-fb818773790a}, named JumpListFix or anything of your liking
  • copy shortcut into %appdata%\Microsoft\Windows\Start Menu\Programs\Startup location, so you don't have to run it manually after each boot.

Notes

  • I have same problem on two different machines with Win 10 Home and Pro, both October 2018, Home is fresh-install
  • When I tried: WinKey+R -> dcomcnfg.exe to check permissions on, I've got warning: The CLSID {c82192ee-6cb5-4bc0-9ef0-fb818773790a}, item C:\Windows\System32\rundll32.exe and title JumpViewerExecuteHelper has named value AppID, but is not recorded under \\HKEY_CLASSES_ROOT\Appid. Do you wish to record it?
  • Adding it have not fixed the problem, fiddling with JumpViewerExecuteHelper permissions with dcomcnfg.exe didn't any good either.
2
  • In my case, I have duplicate entries for the RuntimeBroker in component services. Thank you very much. You've been extremely helpful. I think this problem is still not resolved, as I still cannot fix it at the root. I can only circumvent it temporarily. – Igor Ševo Dec 31 '18 at 16:38
  • I had the same issue and this solution worked for me. – S.C. Mar 16 '19 at 21:30
2

Here is what finally worked for me:

• Run Task Scheduler (Winkey+Rtaskschd.msc)

• Click Action and select Create Basic Task...

• Enter a name and click Next

• Select the When I log on , click Next

• Select Start a program, click Next

• Paste the following script %SystemRoot%\System32\rundll32.exe shell32.dll,SHCreateLocalServerRunDll {c82192ee-6cb5-4bc0-9ef0-fb818773790a} Click Next and select Yes on the pop-up window, then Finish

Restart your computer and hopefully you'll have your problem fixed!

Edit: In case this does not work, try to edit the trigger to Delay task for 1 minute by right clicking the task you created, then selecting Properties then Triggers and Edit...

3
  • As I described in my answer (based on Zenithies' answer), this does work. However, this is not an actual solution, but merely a workaround. What is causing the problem initially? I would like to fix the problem rather than treat a symptom. Cortana is broken along with the jump lists. Something else could possibly be broken with a similar cause. I suspect that the cause is Visual Studio app deployment process, but that needs more investigation. – Igor Ševo Sep 20 '19 at 16:42
  • 1
    @IgorŠevo I am not sure what is causing the problem initially, however I've never installed Visual Studio in the device with the broken jump lists. – Rynigh Sep 21 '19 at 10:50
  • Wow. That's helpful, but now I'm back to no hypotheses. :) – Igor Ševo Sep 29 '19 at 15:30
0

I cannot know exactly what changes were done to your Windows setup, so cannot analyze their effects. Some Windows products don't work well with sensitive folders replaced by junctions, and the installation of Visual Studio is extremely massive, making lots of additions and changes to the Windows system.

In such difficult cases to analyze, the solution might be to use a big hammer - Repair Install. This does an in-place upgrade without losing anything other than all installed Windows Updates. It requires the installed Windows to be able to boot and to run the installation process. It is also very important to use the Windows installation media of the same major version of Windows as is installed. Run Windows Update afterward, as all updates will be lost.

There is no guarantee that this will fix all the problems, since this is not a clean install. Many settings that you changed will stay, so this is not a cure-all solution. But it is better than the destructive Reset or Refresh.

For directions on performing the Repair Install see the article
How to Do a Repair Install of Windows 10 with an In-place Upgrade.

2
  • It seems that the jump lists have a tendency to self-destruct. After a few days of normal work, they are broken again. – Igor Ševo May 16 '18 at 9:43
  • Your setup is self-destructing. I hate to say, but it seems to me impossible to analyze the problem in a non-standard setup such as yours, especially since it doesn't happen elsewhere. I hate to say it, but since this big gun didn't do the job, a bigger one is required. My above link also refers to the Reset and Refresh options, where Reset may optionally at least keep your personal files. Before starting, take good backups including disk image (AOMEI recommended) and test the restoration CD/USB. Next time I suggest avoiding structural changes in Windows - other easy solutions exist, just ask. – harrymc May 16 '18 at 10:42
0

I used the Media Creation Tool to create a Windows 10 ISO file. I then ran an installation of April Update (even though I had April Update installed) to "upgrade" my computer. The installation finished and the problem is now resolved. However, this is not a real solution, considering that it is quite bothersome to have to reinstall Windows every time I update Visual Studio 2017.

I had submitted feedback through the Feedback Hub and a Microsoft engineer replied that the issue was fixed in build 17682. I have yet to confirm this.

Edit (October 2018)

I can confirm that the issue is not fixed in build 17763.1. I have submitted another report through Feedback Hub.

Edit (December 2018)

I have applied a fix from Zenithies's answer. However, this only circumvents the actual problem described in the last edit.

Edit (June 2019, Windows 1903)

I created a scheduled task to run both failing processes (both Cortana and Jump Lists) at log on. I set it to be delayed by 5 seconds. Also, I'm running it with administrator privileges. This resolves the problem partially (I can now use the jump lists). However, the errors are still listed in the Event Viewer. This means that the problem is still unresolved, only circumvented.

I also submitted multiple reports through Feedback Hub, including a link to this post and the related post (Unable to start a DCOM Server).

6
  • I'm happy to know that my suggestion in the comment worked for you, but the normal practice is to invite the commenter to write the answer, and especially when a bounty is involved. – harrymc May 14 '18 at 11:17
  • I don't consider this an actual solution and don't really mean to accept my own answer. It did work, but it seems like an unnecessary effort for something seemingly simple. If by the day before the end of bounty period there is no other reasonable answer, you can write your suggestion as an answer and I will remove this one. – Igor Ševo May 14 '18 at 17:27
  • For a real "solution" one would need to know exactly what changes you have done to Windows that caused the problem, otherwise the only solution is the big hammer. In general, Windows has a very complex structure, too complex even for Microsoft to fully control. Even experts hesitate to make any changes, especially untested ones, since small changes may have unforeseen large effects. But I think that you have found that out by now ;) – harrymc May 14 '18 at 19:20
  • I'm fairly convinced that the installation of Visual Studio is what broke it, but I guess I'll have to wait for the next update. In any case, post your answer and if there isn't a better answer, the bounty points are yours. – Igor Ševo May 14 '18 at 19:47
  • 1
    I've got several versions of Visual Studio installed side-by-side and I update them regularly, with no problems with jump-lists, but my Windows setup is fairly standard with no added junctions. It's possible that the installation in your case was confused by these changes - Windows doesn't always handle junctions correctly. – harrymc May 14 '18 at 20:12
0

I've had this issue with Excel for the last few months; that app seems to be the worst offender. In desperation, I cleared it thusly a while ago: In Settings>Personalization>Start, find "Show recently opened items in Jump Lists on Start or the taskbar and File explorer Quick Access. If it's turned on, turn it off briefly - which will clear all but pinned items from all jump lists - then on again. The Excel jump list started loading again; I'll watch it for at least 2 more sessions to make sure it's resolved.

1
  • I'm aware of this circumvent, but this isn't my issue. In my case, all jump lists are broken (so, no jump lists for any of the apps). – Igor Ševo May 10 at 10:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.