12

recently I tried to access my router's setting via 192.168.0.1 as usually, however, thing is that a year ago I have switched from ipv4 to ipv6 and now ipconfig shows me this:

Windows IP Configuration
Connection-specific DNS Suffix . :
IPv6 Address . . . . . . . . . . : 2a0b:c230:35:204c::7a6
IPv6 Address . . . . . . . . . . : 2a0b:c230:35:204c:7848:3d7f:eefa:cf6a
Temporary IPv6 . . . . . . . . . : 2a0b:c230:35:204c:b89a:cd19:a7bf:d047
Link-local IPv6 Address  . . . . : fe80::7848:3d7f:eefa:cf6a%10
IPv4 Address . . . . . . . . . . : 10.10.10.100
Subnet Mask  . . . . . . . . . . : 255.255.255.0
Default Gateway  . . . . . . . . : fe80::297a:3cfd:fee5:3326%10

Tunnel adapter isatap. <88B01E15-86779-405V-9R1C-3DF84635C612>:
Media State  . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :

Tunnel adapter Local connection* 2:
Media State  . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :

so the question is: how can I access my router ?

I tried:

http://[fe80::297a:3cfd:fee5:3326%10]/:8080

http://[fe80::297a:3cfd:fee5:3326%10]/

[fe80::297a:3cfd:fee5:3326%10]

fe80::297a:3cfd:fee5:3326%10

fe80::3326%10

192.168.0.1

etc..

I am with latest Chrome browser & TP-Link router (which is integrated in the wall - lol, don't ask me why)

4
  • 1
    We need more specifics than you telling us you have a TP-Link router. We need at the very least, a model number, so we can read the manual for the device.
    – Ramhound
    Commented May 9, 2018 at 22:06
  • @Ramhound router model is: TP-LINK TL-WR 841 ND
    – gamer0
    Commented May 9, 2018 at 23:25
  • 1
    After reading up in the manual: static.tp-link.com/res/down/doc/TL-WR841ND_V11_UG.pdf Some parts desribe how to configure IPv6 but other parts like the status page pretend like ipv6 doesn't exist. It could be the router is responding on ipv6 but the web server was never configured for it..
    – jdwolf
    Commented May 12, 2018 at 8:06
  • @jdwolf I am trying to configure a UTStarCom WA3002G4 as an IPv6 router and it works, but the router admin page does not respond on it. I tried both a ULA /48 subnet, as well as the Link Local Address. Possibly you are right.
    – Milind R
    Commented Jan 10, 2020 at 8:29

7 Answers 7

5

The default gateway for an IPv6 will show up as a link-local address (fe80::) used for router advertisements and IPv6 auto configuration. It is a valid address but its not routable. Meaning only your link can get to it. But it otherwise usable. Therefor:

http://[fe80::297a:3cfd:fee5:3326]/

Should work. You need the [] when using IPv6 in a URL.

Just like you do in IPv4 you can also take the address allocated to your computer you take the last segment and change it to the lowest network IP usually 1 except with IPv6 there's no subnet mask just the routing prefix:

2a0b:c230:35:204c::7a6 -> 2a0b:c230:35:204c::1

So http://[2a0b:c230:35:204c::1]

Would also work. IPv6 also has zones which are indicated with % symbols which are used to indicate which interface to use and in urls they must be percent encoded in a URL with %25. But that isn't going to help you since most browsers don't handle them correctly and they aren't needed here.

2
  • On Windows, link-local addresses should work even without zone identifiers (it has methods for detecting the correct interface). But on other systems, the fe80: address won't work like this. Commented May 10, 2018 at 5:43
  • 1
    this is not worked with %
    – JustWe
    Commented May 15, 2020 at 3:44
1

try without the %10 in the address:

[fe80::297a:3cfd:fee5:3326%10]

should be

[fe80::297a:3cfd:fee5:3326]

1
  • Worked for me. Default gateway for me: fe80::1%14. So http://[fe80::1] takes me to the router log in page.
    – iouzzr
    Commented Jan 23 at 10:45
0

According to this bug report, Firefox doesn't support link-local IPv6 addresses in the address bar.

A workaround is to use the link-global IPv6 address of the host (if it's not in a standalone network, of course). According to the Arch Linux manual on IPv6:

If you add an option -I your-global-ipv6 [to ping], link-local hosts will respond with their link-global scope addresses. The interface (%eth0) can be omitted in this case:

ping -I 2001:4f8:fff6::21 ff02::1

Now you know the global IPv6 address of your destination host. Check ip -6 neigh and use it the address bar of your browser: http://[2001:db8::c:d].

0

I acknowledge the OP appears to want an answer for Windows (although they did not explicitly specify an operating system), to which they have received answers from other users.

However, I have an answer for Linux users who came to this page.

On Linux, use the following command to show only the router addresses:

$ ip -6 neighbour | grep router

To expand on this answer: how to access router with IPv6 address?, the link-local fe80 addresses need to be combined with interface.

fe80::1 dev eth0 lladdr xx:xx:xx:xx:xx:xx router REACHABLE would become fe80::1%eth0

Firefox still does not appear to like link-local addresses, so you will have to use Chromium, SSH or something else to connect to the device.

The global addresses of the router can be used as-is.

Edit: The above technically did not answer the question. That only shows how to get the address. Furthermore, it seems like Chromium does not even support link-local addresses (I thought I had used it before). A workaround is https://stackoverflow.com/a/46881540

When IPv6 addresses are used in the context of a web address, they need to be encapsulated in square brackets:

https://[dead:beef::]/ would be used in curl command or web browsers to contact dead:beef:: IPv6 address over HTTPS protocol.

There is a reason why link-local addresses are preferred (despite not being supported by browsers). If you change ISP or your ISP changes IPv6 address across reboots (mine does), then the prefix will change. If your internet connection goes down, your IPv6 prefix will be dropped and your global addresses will no longer work at all. The link-local address gets you into your router, regardless of the state of your internet connection.

0

You know your own global IPv6 address and your router's link-local IPv6 address. And - by networking basics - your router sits in the same network segment as the machine you are working on (by definition of a router). So the global part of both addresses must be the same: 2a0b:c230:35:204c::/64 in this example (as /64 are the smallest IPv6 networks which are can be routed globally).

So it is very probable that the local part of one of your router's global addresses is the same like that in the link-local address. Take your router's address local part (the last 16 "nibbles" - or 8 bytes - or 64 bits) and your global prefix, to get a global IPv6 address for your router.

e.g. with the OP's data:

IPv6 Address . . . . . . . . . . : 2a0b:c230:35:204c::7a6
Deafult Gateway  . . . . . . . . : fe80::297a:3cfd:fee5:3326%10

so combine 2a0b:c230:35:204c:: (your global IPv6) prefix with your router's interface identifier ::297a:3cfd:fee5:3326

You ´d get 2a0b:c230:35:204c:297a:3cfd:fee5:3326 - so use

http://[2a0b:c230:35:204c:297a:3cfd:fee5:3326]/ as URL (worked for me with firefox 110).

3
  • 2
    Your answer could be improved with additional supporting information. Please edit to add further details, such as citations or documentation, so that others can confirm that your answer is correct. You can find more information on how to write good answers in the help center.
    – Community Bot
    Commented Feb 18, 2023 at 19:31
  • Generally this approach is very similar to that of stefan-van-den-akker in his answer but it avoids using any OS specific network tools.
    – village
    Commented Feb 18, 2023 at 19:50
  • I did not use any additional documentation, just my sound basic knowlegde of IPv6 networking and I tried the same in my home network where my default gateway is also a link-local router address - in my case containing ff:fe in the middle of the local part, indicating that it resembles my router's MAC address.
    – village
    Commented Feb 21, 2023 at 22:55
0

running ipconfig /all command within cmd.exe will show under Deafult Gateway an address(es) that are valid to access modem/router

if both protocols are enabled there should be 2 addresses - IPv4 & IPv6

enter image description here

https://www.sony.co.uk/electronics/support/articles/00010017


next, for IPv4 we add http:// (as https:// is not valid in this case) and skip/ignore browser warning about unsecured connection. usually it would be in this form:

http://192.168.0.1

for IPv6 we take the Deafult Gateway and strip it from %... enclose it with [] brackets and add http:// in OP's case it would look like:

http://[fe80::297a:3cfd:fee5:3326]

another way would be to convert IPv4 address into IPv6

we take 192.168.0.1 and convert each octet into binary:

11000000.10101000.00000000.00000001

next we convert it into hexadecimal notation and add ::ffff: in front of it:

1100 (12 in decimal) corresponds to C in hexadecimal
0000 (0  in decimal) corresponds to 0 in hexadecimal
1010 (10 in decimal) corresponds to A in hexadecimal
0000 (0  in decimal) corresponds to 0 in hexadecimal
0000 (0  in decimal) corresponds to 0 in hexadecimal
0000 (0  in decimal) corresponds to 0 in hexadecimal
0000 (0  in decimal) corresponds to 0 in hexadecimal
0001 (1  in decimal) corresponds to 1 in hexadecimal

_____________________________________________________

::ffff:c0a8:1

so the final form of http://192.168.0.1 would be:

http://[::ffff:c0a8:1] 
-1

How come nobody's pointing out that in the Windows IP Configuration text posted by the asker, it clearly reveals his IPv4 address as 10.10.10.100, meaning that his router should be accessible at the following address:

http://10.10.10.1

To answer the specific question about accessing the router, using the link-local gateway address after stripping the "%" and interface code at the end should definitely work. In effect, the correct router IPv6 address is:

http://[fe80::297a:3cfd:fee5:3326]

I tested my router's IPv6 link-local gateway address (http://[fe80::xxxx:xxxx:xxxx:ef28]) in two old browsers: Opera 54.0, released way back in June 2018, and Chrome 68.0.3440.106, released in August 2018. Both browsers allowed me to login successfully, so I don't know why other users reported that Chrome wasn't working. Hope this helps future users.

1
  • 1
    there is no rule or spec stating that the gateway will be at a .1 address. Many exist at 254, or some other arbitrary number...subnet mask could also allow the other octets to vary as well.
    – Brian
    Commented Feb 23, 2023 at 20:14

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .