0

First off, sorry this is here. To register with Mozilla and ask for support there, I need my e-mail working, but my Mozilla Thunderbird e-mail client suddenly isn't working, so I can't do the e-mail registration. C'est la vie.

Anyway...

I'm using Linux Mint 18.3 Cinnamon 64-bit. The last updates were applied on the third of May, and did not include Thunderbird. The last Thunderbird update seems to have been off the bottom of my Linux Mint updates history (6th April). Thunderbird version is 52.7.0 (64-bit). I've obviously checked e-mails many times in that timescale, including several times today.

I've been using Thunderbird for a few years on this Linux Mint install, running through updates from Linux Mint 17.something (profile originally copied from Windows 7). The profile is in the ~/.thunderbird folder, and seems consistent with the profile.ini. I haven't touched this since transferring the profile a couple of years ago, until after the problems started about half an hour ago.

The problem - I launch Thunderbird and get the "Welcome to Thunderbird" dialog that wants to set up new e-mail accounts. It seems to be ignoring the existing profile.

However, it doesn't create any other folder or profile - except that after I updated my backup (which I realise I stupidly haven't updated for quite a while) and tried shifting the profile to another folder (apparently Thunderbird on Linux can sometimes use a ~/mozilla-thunderbird folder) starting Thunderbird recreated the ~/.thunderbird folder with a new profile.ini and profile. Obviously I deleted that and moved the original back, but still, Thunderbird is acting as if there's no existing profile (with 450MB of important e-mails that I need) yet not creating a new profile folder when I start it up.

Any ideas?

Is there e.g. any way to check a profile for corruption, figure out how that could have happened, and maybe repair it?

There do seem to be a files in the ~/.thunderbird/Crash Reports folder, but the filenames all start with "InstallTime" (I also don't remember any crashes at all) and the most recent is "InstallTime20180326200027".

  • I'm investigating now whether this is the same problem, but folderTree.json doesn't appear to be corrupt, at least at first glance (it looks like a json file, all on one line as often happens for sort-of-but-not-really-human-readable files, looking at it in gedit). – Steve314 May 9 '18 at 23:04
  • Removing the folderTree.json file didn't help - Thunderbird still opens as if it's a new install (but without creating a new profile AFAICT), the folderTree.json file isn't recreated. – Steve314 May 9 '18 at 23:08
  • 1
    Take a look at Create a new profile and copy the old one over it (and other advice on the same page). – fixer1234 May 9 '18 at 23:48
  • @fixer1234 - No luck so far. Currently trying copying the profile to a Thunderbird install in an offline Windows 7 VM, but that will take a few minutes. – Steve314 May 9 '18 at 23:57
  • Installed a clean Thunderbird 52.7.0 in a Windows 7 VM that's never had that installed before. First run then exit, then replaced the profile and profile.ini with the ones from Linux, then tried to run again. Got a messagebox - "Profile Missing" and "Your Thunderbird profile cannot be loaded. It may be missing or inaccessible.". Have done basic checks that it's in the right place (profile folder copied into AppData\Roaming\Thunderbird\Profiles, profiles.ini into AppData\Roaming\Thunderbird). Now going back to the instructions to make sure I haven't missed something silly. – Steve314 May 10 '18 at 0:11
1

I've faced the same problem and I've been able to solve it as follows:

  • cd /home/user
  • tar cvvfz backup.tar.gz /home/user/.thunderbird/ (just in case....)
  • cd .thunderbird/
  • In case that you have several profiles you need to figure out the ones that you are using (I did it by inspection, based on file sizes and folder names)
  • Edit the profiles.ini file and leave only the sections related to the profiles that you need to save, deleting all other sections
  • Restart thunderbird and select the default profile in the popup window.

Hope this will be of help.

| improve this answer | |
0

My solution was a variation on the solutions recommended in comments and in this link. The difference is I recreated my e-mail accounts in a new clean profile, then copied the minimum in from the backup, so what I overwrote wasn't a completely empty profile. Steps are...

  1. Delete the ~/.thunderbird folder (after making a backup, of course)
  2. Run Thunderbird, and create a profile with my existing e-mail accounts set up, based on the account information I had elsewhere, carefully avoiding triggering any downloading of e-mails.
  3. Exit Thunderbird.
  4. Copy the contents of the Mail and IMapMail subfolders from the backup profile to the newly-created profile. Getting the subfolders within this to match exactly needed some care in step 2 (manual configuring to override automatic selections) and a second attempt because of preferred server information that's changed over time, but otherwise this was no problem.
  5. Copy the abook.mab (address book) file from the backup profile to the new one.
  6. Load Thunderbird and check everything's intact (and get slightly stressed when the inbox for one account started filling up with every e-mail I've received since early 2015).

I still don't know what the problem was, but the way Thunderbird is configured is slightly different to before - previously one e-mail account (the one that downloaded all those old e-mails) was combined with the local folders, now both e-mail accounts are separate from the local folders, though there's still an empty useless inbox in the local folders. Maybe I had issues because of an ancient way of configuring that isn't really supported any more, or maybe that's all irrelevant.

There's a lot of files I didn't copy out of the original profile, but none seem important to me, and every extra file risked recreating the problem.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.