1

How can I (in order of preference):

a) make lxterminal fake transparency work in JWM b) make another lightweight terminal transparent or fake-transparent in JWM c) make trasparent ONLY the terminal in JWM using compton

In the lxterminal configuration file I tried to set bgtransparent=true and bgalpha=(various integers) but it didn't work. Also in the edit/configuration menu there is not option for setting transparency.

1 Answer 1

1

OK, solved this one myself. I'll post here in case anyone has the same question.

These are the steps I've taken:

  1. installed: compton, transset-df, devilspie
  2. set all opacity parameters in JWM to 1.0 (that means putting the line:

    <Opacity>1.0</Opacity> 
    

    in the .jwmrc config file for each element like windows style, menu, etc.) so they won't be transparent

  3. created the file .devilspie/opacity.ds in my home dir

  4. run command

    $devilspie -a 
    

    in terminal to find identifier for lxterminal

  5. put the following code in the opacity.ds file:

    ( if
    ( or
    ( contains ( window_class ) "Gvim" )
    ( contains ( application_name ) "lxterminal" )
    )
    ( begin
    ( spawn_async (str "transset-df -i " (window_xid) " 0.85" ))
    )
    )
    

    where 0.85 is the opacity level (can be anything from 0.00 to 1.00)

  6. Added the following commands to .jwmrc:

    <StartupCommand>compton </StartupCommand>
    <StartupCommand>devilspie -a </StartupCommand>
    

If you use Conky, it has its own transparency setting in its config file. Further information can be found at:

https://wiki.archlinux.org/index.php/Per-application_transparency

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .