1

I'm trying to get Windows 10 to play nice in a dual-boot setup with Antergos as the other OS, but I don't want to have to toggle Secure Boot every time I want to switch OSes, and I'd much rather not have to go through the hugely inconvenient and cumbersome process of reinstalling GRUB with Secure Boot keys, shim, efitools and all the works. Is there any way to get Windows to boot in UEFI mode without Secure Boot if it was installed with Secure Boot?

As it is, if I boot Windows from the GRUB menu, it shows the Windows logo for several seconds and then suddenly reboots. If I enable Secure Boot, Windows boots into recovery mode after a Secure Boot error, but I can click the normal boot option which causes the PC to reboot and show the message again, but then Windows boots perfectly normally afterwards. And then I have to go back in the BIOS if I want to switch from Windows to Antergos.

I'm on an Alienware 15 R2.

1

I managed to fix the problem by disabling legacy boot/BIOS support in the BIOS menu. Windows 10 now boots normally and without errors.

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.