After several hours of frustration, I'm giving up.

The default trackpad driver of the Asus UX303U is truly catastrophic. I downloaded ELAN driver 16.21.13.3 which is fantastic, but I am not able to turn on two finger scrolling. (On Windows 10 Home 64 bit.)

There's a lot of online content about this, but nothing works for me.

  1. Going to Settings and then Touchpad, I get the Your PC has a precision touchpad. Scrolling down there are many options and among them is Drag two fingers to scroll under Scroll and zoom. Checking them has no effect.

enter image description here

Under Related settings, going to Additional settings and then to the ELAN tab, the options button is greyed out as depicted below. So I cannot access that either.

enter image description here

  1. When I run ETDAniConf, I get the blank window below. Running ETDSimpleUI gives an ETDSimpleUI has stopped working error.

enter image description here

How can I enable two finger scrolling? I am desperate.


Added. Screenshot of Hardware tab.

enter image description here

  • Are you sure you used c:\program files\elantech\ETDSimpleUI.exe? Look in this folder for other programs with similar names and try them. Try also adjusting sensitivity settings, palm rejection, tapping speed etc. if you can. Asus itself recommends a much older driver for the TouchPad from 2015/11/13, but a relatively new BIOs from 2017/09/11, and both may be worth trying. – harrymc May 15 at 12:51
  • Can you add a screenshot of your Mouse Properties window's "Hardware" tab? – 3D1T0R May 15 at 15:11
  • @3D1T0R added to the post. – Arrow May 15 at 17:37
  • @harrymc unfortunately I don't even have such an .exe file anywhere on my computer. – Arrow May 15 at 17:38
  • Do you have an elantech (or similar) folder anywhere and what .exe files does it contain? – harrymc May 15 at 17:54

I wanted to comment, but my reputation is too low.

Therefore, in an answer: did you try to uninstall the ELAN driver and the default touchpad driver, rebooted your pc and tried to download and install again the ELAN driver? Also, I found this question on the white screen of the ELAN settings: Elan Smart Pad - empty settings window; small chance that the first answer would help you:

Go to the registry key HKEY_CURRENT_USER\Software\Elantech\SmartPadDisplay and change all values to 1.

  • Dear DaanR, thanks for your help. Unfortunately your suggestion did not help me. – Arrow May 15 at 11:34

The ELAN software is normally installed in the folder C:\Program Files\elantech, but you are missing all the .exe files that should be present there (list).

So your driver installation seems broken to me.

Try to uninstall the driver and reboot to let Windows install its own driver.

If that doesn't work, try the older driver that is recommended by Asus.

If this still does not work, let us know from where you got your Elan driver, for verification.

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.