3

I got too large spacing between words in Word. What may be wrong in the case?

Enter image description here

I tried this and it did not help.

2
  • 1
    This happens in justified text when the next word (your URL) is nearly a line long and cannot be split. You can either insert a new-line before the URL or change the text to left-aligned.
    – AFH
    May 11, 2018 at 17:08
  • You can also use Ctrl+- to insert optional hyphens into Word. If the hyphen can be used to narrow the word spacing in a justified paragraph, Word will do so. Make sure you use the hyphen above your letters, not the one in the number pad though.
    – PProteus
    Jan 14, 2020 at 14:40

4 Answers 4

7

There is nothing “wrong”; the program is behaving as designed. Your paragraph format is set to justified, and you have very little text before the URI, which Word will not break by default unless it contains a space or a hyphen. Set the paragraph justification to left for this paragraph, and the space will be closed up, leaving a short line before the URI.

Alternatively, insert a “hard return” (shift-enter) right before the URI, and that will collapse the space as above.

0

A good way to fix the look of such lines without changing justification is to insert Zero Width Space character(s) inside the very long word/expression (usually hyperlinks). Put this character after slashes (or in other places) and the link will be nicely divided.

This is a better solution than using Shift+Enter because if you copy such line (for example to Notepad) this will still be single, not divided line.

To insert Zero Width Space go to Insert tab, click Symbol, click More Symbols, type: 200B in Character code field and click Insert. From this dialog box you can also assign a keyboard shortcut for this character to make things faster.

2
  • What the difference between this and inserting spaces before the link? Nov 18, 2021 at 10:58
  • The difference is that if you copy the modified link, there will be no space in it - the link will still work, and if you insert a space - this space will be copied and the link will be broken.
    – endrju
    Nov 22, 2021 at 9:38
0

Well, in fairness there is something "wrong" from a logical, layman user perspective. For example, this issue can occur if the text is immediately followed by an image (such as a snip).

Just adding a return in-between the text and the image fixes the issue, which isn't an intuitive action.

0

Open a Word file whose character spacing you know is correct. In File > Options > Advanced > Layout Options for [filename], jot down what is checked and unchecked. Then, go to your problem file and make sure that the same items are checked and unchecked. For me, it was "Balance SBCS characters and DBCS characters" causing the extra spacing. The problem arose because I downloaded files from the Internet as rtf's, then saved as docx.

Other possible settings are shown at: How to remove extra spacing between words in Word 2010?

(Rand's answer.)

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .