42

So I recently wiped my hard drive and did a clean install of Windows 10 using the Windows 10 media creation tool (which includes the May 2018 update). Since then, every time I log on using my MS account, I also get a blue screen telling me to "Use Windows Hello instead of your password". No option to cancel, just a 'Next' button: Prompt to create a PIN screen

This takes you to a screen where you can cancel and then back to a "Did you mean to cancel PIN?" screen with a 'I'll set up a PIN later' link: Cancel screen

Every. Time. I. Log. In.

Anyone know how to disable this very annoying behaviour?

I've tried:

N.B. Using Windows 10 Prof (at home so not on a domain)

Workaround

I set up the PIN to be the same as my password (after ticking the 'Use letters and symbols' box):

Set up PIN dialog box with 'Use letters and symbols' ticked

14
  • 1
    @LPChip: If you click 'I'll set up later' it just prompts the next time you log in. Could try a local account I guess but Windows really pushes you towards a MS account as well...
    – pelms
    May 12, 2018 at 22:49
  • 4
    I get this too and it's really irritating. Every bloody startup! May 13, 2018 at 9:29
  • 1
    What if you actually setup a pin, and then remove it?
    – LPChip
    May 13, 2018 at 9:56
  • 1
    I'm also getting this on a Win10 Home after the 1803 update
    – MOnsDaR
    May 21, 2018 at 18:46
  • 6
    Every. Time. I. Log. In. Who approved of this design decision? If I say "no" once, don't keep forcing your feature down my throat every time I want to sign into my computer.
    – whiteshooz
    Dec 10, 2018 at 18:08

6 Answers 6

26
  1. Run gpedit.msc.
  2. Select Local Computer Policy / Computer Configuration / Administrative Templates / Windows Components / Windows Hello for Business
  3. Set the "Use Windows Hello for Business" policy to Disabled, and click "Apply"
  4. Reboot
5
  • 1
    I wonder who downvoted this answer? It's effective in remove the prompt screen at boot-time, however the hidden app in task switcher annoyingly remains.
    – Sajuuk
    Dec 7, 2018 at 13:30
  • 4
    For this to work, you need Windows 10 Pro. Turns out I had Windows home, but a free upgrade to Pro that I had not activated (yay). Windows 10 Pro gives you access to gpedit.msc. Other ways of getting gpedit.msc seemed hacky or insecure. This solution is the correct one that actually works.
    – Jake88
    Jan 3, 2019 at 20:50
  • On Win10-Po. Didn't need to reboot. Only logout and login again.
    – Ray Oei
    Feb 1, 2019 at 20:53
  • 2
    This fixed it for me. I didn't even have the option to skip creation of a pin. It just asked me if I'm sure that I wanted to cancel pin creation and the only button was to create one. Very annoying.
    – Lunyx
    Aug 6, 2019 at 19:28
  • This does not work, it makes the problem worse by disabling the pin and requiring account recovery every login.
    – thesmart
    Dec 10, 2020 at 0:29
22

I have also had the same problem. The answer was not where I expected it to be.

Log on, cancel the PIN prompt as in the OP. Then, when you're at the desktop, click the Windows Defender Security Centre icon on the tray. Under "Account Protection", it should say "Set up Windows Hello for faster, more secure sign-in".

If you click "Set-up", it will prompt you to set up a pin, so don't do that. Instead, click "Dismiss" and that should be that. After doing this, my laptop stopped prompting me to set up a pin on logon!

Incidentally, while I had this problem, when I got to the desktop, I had an Explorer window that I couldn't get rid of. It was off-screen, but the taskbar icon was still present for it. The title of the window was "Microsoft Account". Task Manager showed it as not responding, and killing the task in Task Manager got rid of it successfully. This window did not re-appear after following the procedure above to get rid of the PIN setup.

4
  • Thank you! I've had this issue for over a week and nothing has worked - Registry edits, group policies, settings in user access control. Finally it's gone. MS really need to sort out their entire account validation process as whichever MS technology you use, Windows, Azure, Office etc, it's always a nightmare. Jun 21, 2018 at 15:30
  • 6
    Doesn't work came right back
    – JPM
    Jul 26, 2018 at 1:35
  • 1
    Like JPM pointed out, this solution doesn't work. The solution suggested by Badhras below works.
    – Jake88
    Jan 3, 2019 at 20:55
  • 2
    Not applicable anymore with latest Windows 10, does not work. I haven't been able to find any other way either :-( May 24, 2019 at 8:13
5

I did find a solution to this. I thought I just posted this, but it didn't show up, so sorry if it double-posts. The next time you logon, notice there are two icons under where you put in your password. The one on the left is for pins and the one on the right is for passwords. Just highlight the one on the right. Now you can logon with your password and you will not be prompted with the setup a pin wizard.

1
  • 1
    looks like it resets back to pin after log out and log in, have to re-select password to keep the pin wizard from kicking off again
    – workabyte
    May 20, 2018 at 15:30
1

It might be useful to disable Windows Hello entirely, if you don't want to use it. Open Settings. Click on Accounts. Click on Sign-in options. Under Windows Hello, click Remove.

4
  • At least on Windows 10 Home it just says that Hello is not available on my machine. But I get the wizard op is describing too.
    – MOnsDaR
    May 21, 2018 at 18:47
  • Says its not available on my computer
    – JPM
    Jul 26, 2018 at 1:34
  • 1
    I have seen this advice on a couple of websites, but the Remove option isn't there for me on Windows 10 Pro (off-domain, local user account). I think the latest update was applied to my computer a week after your answer, so something might have changed. Aug 14, 2018 at 22:20
  • interesting weird consequence is failing to establish VPN connection from tray menu. After Hello disabled it always fail, nd only establishing VPN through settings window works Apr 3, 2020 at 8:47
0

I tried signing out of my Microsoft account and making my user profile a local account and that worked. Not sure how to get rid of it if you want to keep a Microsoft account connected.

-1

These registry settings worked for me (I use Windows 10 Home with Microsoft account):

[HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\PassportForWork]
"Enabled"=dword:00000000  
"DisablePostLogonProvisioning"=dword:00000001
0

Not the answer you're looking for? Browse other questions tagged or ask your own question.