0

Windows 10 RDP behaviour seems to have changed post April update. Same hardware, same mouse, same OS, same everything.

I'm connected to a remote session (Windows Server 2012 R2) and am experiencing this in Notepad, Notepad++, Textpad and Visual Studio Code:

Typing Shift+'and then u does not print "u and instead prints Ü

For example: to type

 $sql="update

I type $ s q l = (shift+') u p d a t e

Expected result:

 $sql="update

Actual result:

$sql=Üpdate

To get around this new and annoying issue I am typing shift+' shift+' (twice) to print "" and then moving the cursor back inside the quotes to type update.

  • Something to do with international keyboard layouts at one end or the other ... – DavidPostill May 13 '18 at 19:57
  • @DavidPostill that was my first thought and checked if the update changed my keyboard/language settings. It is set to English (United States) US Keyboard. – sikander May 13 '18 at 20:04
  • Hmm, RDP Advanced configuration to change the default keyboard layout? – DavidPostill May 13 '18 at 20:10

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.