1

I'm conducting a task that entails selecting a few words from a table cell in order to highlight them. I'm doing this hundreds of times over a number of different documents. The amount of text in the table makes the keyboard impractical. If, whilst I'm highlighting part of the final line of a cell, my mouse gets too close to the cell border, the entire cell contents become selected. Is there a way to disable this behaviour, or do I just need to slow down and hone my mouse skills?

  • 1
    You can use mouse and keyboard both to get desired result. Put cursor at start location using mouse. Then scroll to desired end location, press and hold Shift button before clicking mouse at end location. – Sandeep May 14 '18 at 13:29
1

According to my test, this only happens if the mouse touches the separator line between columns.

You may click at the starting position and, while holding Shift, click anywhere in the empty space between the text and the column separator. This will select the text to the end of the cell. But if the selection starts in the middle of a word and then crosses word boundaries, the default action of Word is to select the entire first word.

  • You can change this default, see superuser.com/questions/1030453/… – Aganju May 14 '18 at 14:41
  • 1
    @Aganju: This is only the option for automatically selecting entire words, which is not the main question here. – harrymc May 14 '18 at 14:49
  • But it affects table cell selection too, I just tried. It doesn't say it explicitly, I know. – Aganju May 14 '18 at 14:50
1

You should change the default selection mode in Word, see Stop MS Word from selecting more than I want for details ('Under File/Options/Advanced, there is the option 'When selecting, automatically select entire word'. It is on by default, you can switch it off.').
That way, the cell gets not automatically selected (you'd have to double-click it to still get the whole cell, if you wanted that)

  • This is a useful tip, thanks, so +1! But the cell still gets selected in its entirety if I clip into the margin, and stays that way when I move the cursor back into the cell, so it doesn't help with my original question. – ms609 May 15 '18 at 12:54
1

From what I read here, no one has an answer to the question. They answer for a WORD and a PARAGRAPH, but either no one reads the question, or no one knows an answer.

We don't want to click on the first and last letters of what we want to delete or move

we don't want to stop whole words or whole paragraphs from being selected

I already have the 'select entire word' and 'use smart paragraph' check boxes unchecked

Based on the number of times superusers have answered a question that wasn't asked, my conclusion is that there is no answer. That's my answer to the question.

-1

File, Options, Advanced near the top, sixth check box uncheck the use smart paragraph selection

  • Welcome to Super User. Is this different from Aganju's answer? – timotree Mar 30 '19 at 22:28
  • "When selecting, automatically select entire word" ≠ "Use smart paragraph selection". So this answer is different. – Scott Mar 30 '19 at 23:27
  • it is different but after using it for a while--fail. does not solve this problem at least for me. – Jim Hanson Apr 1 '19 at 2:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.