12

I am trying to run a curl command and getting this error:

'http" not supported or disabled in libcurl

I looked where I have curl.exe, found it in C:\Program Files\GDAL and deleted it.

The error persisted. This was curl.exe in C:\Anaconda3\Library\bin, so I deleted it too.

The error still persisted. There was one more curl.exe in the $PATH.

So error is independent of the executable. How can I fix it?

  • What is the output of curl --version ? – bertieb May 14 '18 at 14:49
16

Ensure you are supplying curl with double quotes ("), not single quotes (')

Curl in Windows is know to not like single quotes as per (for example) this thread:

D:\nr\platform_installer_win32>curl -X GET 'http://api.newrelic.com/v2/applications.json' \ -H "X-Api-Key:${APIKEY}" -i
curl: (1) Protocol "'http" not supported or disabled in libcurl

(...)

I believe the first warning you're seeing is due to wrapping the url in single quotes instead of double.

(from NewRelic forums, emphasis mine)

This also popped up in a QA over on StackOverflow.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.