1

I'm running OpenSUSE 42.3 on my desktop. It's installed on 250 gb SSD with LVM. There's two logical volumes: one for root partition, other one for home partition. My root partition was only 40GB, so it got full. I didn't notice that until there was no space left at all. After that A LOT of stuff stopped working. I wanted to install baobab (disk usage analyzer), but zypper didn't work, YaST wouldn't open either, I typed my root password and nothing happend. I tried to use some commands to find big files on my root partition, but they also won't working because sort command needs to create a file in /tmp and I don't have space there. I erased all the logs and temporary files, but that didn't free much space. I decided to resize my logical volumes: reduce my home partition by 10GB and add 10GB to my root partition. I ran lvreduce -L -10G -r /dev/mapper/system-home, but it used fsadm to resize the filesystem, and fsadm needs to create a temporary file, and again, I don't have space for that. What can I do?

1

Use a live system

If I ended up in a situation like this I would simply find a suitable live system. Boot from the live CD or USB stick, then from within that system, activate the volume group.

You can now use the tools from the live setup to perform the trickery, for example growing or reducing volumes.

After you have added some space, you can boot back into your normal system and start cleaning up. Cleaning up is easier when you have some scratch space for the tools to work with.

0

First of all you can clean zypper package cache with sudo zypper clean --all, it probably will clean enough, so you can resize fs.

0

When your OS has no room to breathe, a bootable external or optical disk of some sort is what you need. A disk like the Ultimate Boot CD will have tools that will allow you to resize the partitions and/or modify the data to free up space. I don't know why you have 40GB in root though. If you're using root as your only user, you can have more problems than just this.

  • I think he's talking about the filesystem root, /, not /root. – pipe May 15 '18 at 12:48
  • Yes, I mean the filesystem root – user886545 May 15 '18 at 12:50

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.