2

Like many here I do admin for some family and friends. In the past I've used a few apps but Teamviewer (TV) has been the best for my situation, now however I'm finding that it can't be used because it's blocked by my friends browsers!?

Obviously it's difficult because I'm getting this second-hand, checking with Browserling there doesn't appear to be a problem - but the last two times I've tried to get someone to download TV [both are on Win10] then they've said that the browser gives them a message that the site "isn't secure" and so they can't download the client.

One has Ad-Aware anti-virus and that blocked emails that I sent with the TV quickstart app and/or a link to the same. Facebook even refuses to send a message with a link to Teamviewer.com and bit.ly appeared to provide a work around but failed to link my friend to the website (worked for me, not for them, don't know which app is blocking that).

So ... is there anything I can do to set up an ad-hoc support session?

They're not up to doing things like finding an IP address for me, at least not without it being like wading through treacle carrying a two year old, and certainly won't be able to check ports are open and such. I'm on an Ubuntu variant and they are on Windows 10.

When I next have access then I'll patch something together with either tightvnc or Teamviewer, but the whole point is remote support and minimising me driving around the countryside just to find the right box to type a password in or whatever needs doing this time.

Any advice?

closed as too broad by Ramhound, fixer1234, n8te, Twisty Impersonator, LotPings May 17 '18 at 20:38

Please edit the question to limit it to a specific problem with enough detail to identify an adequate answer. Avoid asking multiple distinct questions at once. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

  • 1
    I've never encountered that message when using TeamViewer, but you can try join.me instead. – wysiwyg May 16 '18 at 20:03
  • 1
    Are you saying TeamViewer the client is blocked or the website? You should edit the question to include this vital information. – Ramhound May 16 '18 at 21:37
  • Well it's access to the website, but also receipt of links, receipt of exe files .. systemically it's difficult, but primarily the website, I guess. I suppose I could snail-mail a USB drive. – pbhj May 17 '18 at 12:33