Must I change the name of my computer to change the name that Outlook relays, or is there a setting that Outlook uses that is initially the computer name but can be set by a (non-programmer) user, e.g. registry setting?

Below is the header of an email I sent to another email address on my domain (example.com). I received it since all emails for my domain get routed to my email account.

It happens not only with my domain though. I sent the same email to Gmail, took a look at the header, and the same identifying computer name appeared in that header also.

See helo=NameOfMyComputer:

Return-Path: <sender@example.com>
Delivered-To: sender@example.com
Received: from mail.emailserver.com
    by mail.emailserver.com with LMTP id mARWCHyv/FpHgAAAiOHS9w
    for <sender@example.com>; Wed, 16 May 2018 18:23:56 -0400
Return-path: <sender@example.com>
Envelope-to: receiver@example.com
Delivery-date: Wed, 16 May 2018 18:23:56 -0400
Received: from [] (port=37178 helo=NameOfMyComputer)
    by mail.emailserver.com with esmtpsa (TLSv1.2:ECDHE-RSA-AES256-GCM-SHA384:256)
    (Exim 4.91)
    (envelope-from <sender@example.com>)
    id 1fJ4pv-0008XV-IV
    for receiver@example.com; Wed, 16 May 2018 18:23:56 -0400
From: "Sender" <sender@example.com>
To: <receiver@example.com>
Subject: Somethinginteresting
Date: Wed, 16 May 2018 15:23:55 -0700
Message-ID: <00e601d3ed64$957c4c20$c074e460$@example.com>
MIME-Version: 1.0
Content-Type: multipart/alternative;
X-Mailer: Microsoft Outlook 16.0
Thread-Index: AdPtZJL7oGrugVdcQnC0jxSqvozmog==
Content-Language: en-us
  • 1
    What do your SMTP settings look like in Outlook? Have you tried sending an email to a completely different email account and checked the headers? This might only happen when you send mail to yourself. It’s not an Outlook issue, the SMTP protocol specifies providing the hostname in the helo command. It just usually isn’t passed along to recipients because the mailserver you use will specify itself on outgoing mail. – Appleoddity May 17 '18 at 4:22
  • SMTP settings?? Uh, encrypted and port 465? Gmail shows same information. Outlook is sending this information to the SMTP server so it is an Outlook issue. The SMTP server does not know the name of my computer. I am asking how to change the information Outlook send to the SMTP server. – zylstra May 18 '18 at 6:05
  • You’re not being very helpful. You’ve blacked out all the information in the headers so it is useless, and there are more than two settings in SMTP. This is not an Outlook issue. The SMTP protocol defines the HELO command to provide the hostname of the sending system. Outlook is following the rules. Your mail server or your SMTP settings are the problem. This is not normal behavior. And I also asked another important question you didn’t answer. – Appleoddity May 18 '18 at 11:26
  • Specifically, is this a gmail account? Have you tried sending mail to, and checking the headers of, a recipient that is not gmail? Are you using SMTP authentication when sending mail? Mail between two recipients on the same server, including yourself is likely going to show the hostname of your computer. And if you send mail to an outside recipient, it will show the hostname of the gmail server. It’s just the way SMTP works. – Appleoddity May 18 '18 at 12:11
  • I meant to be helpful. I did answered your questions, although it may have appeared as if I didn't answer one of them - see clarifying info in my updated question. This is not a Gmail account; it is on a server that I host. Yes, I use authentication, as evidenced by my earlier answer of port 465. – zylstra May 18 '18 at 18:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.