3

Recently, I am experience slow access to Google related website. Whenever I visit a google related website, it take very long time to load. Then, I found out it is because my PC is hard connecting to Google sites. So I try to ping google.com from CMD, it shows Request timed out.

If I unplug my network cable and re-plug again, everything works fine. Ping to google also works fine. However after several minutes the problem occur again. And this only happens on my PC while other PC on the same network works fine.

Also, I found out that when the google IP is IPV6 it will fail. When the IP is IPV4, then it will success.

Pinging google.com [2404:6800:4001:807::200e] with 32 bytes of data:
Request timed out.
Request timed out.
Request timed out.
Request timed out.

Pinging google.com [216.58.196.46] with 32 bytes of data:
Reply from 216.58.196.46: bytes=32 time=22ms TTL=57
Reply from 216.58.196.46: bytes=32 time=24ms TTL=57
Reply from 216.58.196.46: bytes=32 time=26ms TTL=57
Reply from 216.58.196.46: bytes=32 time=24ms TTL=57

How can I fix it?

2
  • Does your ipv6 setup work for anything else? – Mikael Kjær May 17 '18 at 7:21
  • @MikaelKjær After some testing, I just found that my internet doesn't work for IPv6. If this is the case, how can I prevent accessing the website via IPv6? – user1995781 May 17 '18 at 8:16
5

It seems like your problem is with badly configured IPv6.

If you want to properly configure IPv6 you would need to provide more details or talk to your network administrator or ISP (depending on if it's a home or work network).

My recommended work-around for now would be to install the "Prefer IPv4 over IPv6 in prefix policies" from Microsoft which would try IPv4 before IPv6.

If that doesn't work you can try the "Disable IPv6 on nontunnel interfaces (except the loopback) and on IPv6 tunnel interface" from the same link.
Please note the first way is preferred so you still have ability to connect to IPv6 networks in the future.

5
  • 2
    IPv6 shouldn't be disabled this way. For more informations look here: serverfault.com/questions/179954/… – marsh-wiggle May 17 '18 at 8:48
  • Thanks. Not a daily Windows user myself. I'll update the answer. – Mikael Kjær May 17 '18 at 8:49
  • 1
    I would start by disabling IPv6 transition stuff only, and seeing if that fixes the problem. That is, Teredo, 6to4 and ISATAP. – Michael Hampton May 17 '18 at 12:39
  • @MikaelKjær It seems to be the problem with my computer. Today, I test with my phone (by connect to the wifi on the same network), it has no problem accessing IPv6. So, how can I fix the IPv6 problem on my PC instead of disable it? – user1995781 May 18 '18 at 3:01
  • I doubt I would be able to answer that but I would recommend adding details about how you connect to IPv6, like is it ISP native or tunneling. Also if it is your private network or a work network. – Mikael Kjær May 18 '18 at 16:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.