0

I have an M.2 drive that I'm currently trying to install Windows 10 x32 on (we need the 32 bit version for work apps). Installing Windows 10 x64 works just fine, but trying to install the 32 bit version from the same Microsoft-provided USB install stick doesn't work.

Facts:

  • In UEFI boot mode, the install works for x64, but doesn't even get to the Start Install page for x32: After selecting Windows 10 32 bit UEFI
  • In Legacy mode, I get the Start Install page, but when I get to the Select Partition page, Windows won't let me install onto my M.2 drive. I don't have this problem for x64. enter image description here
    The popup is what you get when you click the Windows can't be installed on this drive link on the bottom. If you ignore that and click next, it will give you the following screen.
    enter image description here

  • This is different than the GPT/MBR error. I've also tried formatting the disk, and converting it between GPT and MBR. No dice.

  • I get the same message whether run the installer on my laptop (Lenovo T470p -- where the drive will eventually be going), or desktop (Dell OptiPlex 3040, through a PCIe adapter).
  • I've installed and booted Win10x32 installations on the desktop before, so I'm doubtful it's a hardware problem on that side.

Note that the M.2 drive came with the laptop, and the specs say it should be compatible with Windows 10 x32. We've spoken with tech support (shutter), and they've confirmed this as well, but they weren't able to tell us how (at least not at the level we got to).

Research:

According to this dell support page,

Supported BIOS Types

  • The UEFI BIOS is currently the only one which supports these devices.
  • Always make sure you have the latest revision of your BIOS installed.
  • Make sure that your BIOS is configured to use the EFI boot loader.

This may or may not be applicable to Lenovo systems as well.

I've seen a bunch of questions on the internet (and SU) on how to install Win10x64 if that's not working, but my question is specifically about the 32 bit version, since the 64 bit version works.

Is there anything I've missed? I'd be more than willing to try out a list of configurations if you need more info; I've pretty much hit a brick wall. We ordered another M.2 drive that should get here today as well. I'll update with how that one goes.

Edit: Different than this question. That question is for 64 bit installs, and I've tried the suggested answer there (removing all other drives), to no avail.

  • What applications are not compatible with Windows 10 x64? – essjae May 17 '18 at 17:36
  • 1
    Our (work) ERP system was originally built for Windows 98/XP, and will not run on a 64 bit operating system. Period. Originally it wouldn't even run on Windows 10 at all, but I spent 3 months or so researching and got it working on 32 bit. – Cullub May 17 '18 at 17:49
  • 2
    Sounds like a candidate for virtualization. – Ignacio Vazquez-Abrams May 18 '18 at 3:49
  • time to update your ERP system as well. But in the mean time running in a virtual machine may be the solution – phuclv May 18 '18 at 16:13
0

Download the 32bit version of windows as ISO file and use WinToUSB to install the ISO on your hard drive whilst it's mounted on another computer.

Demo of WinToUSB Here

  • Should I format the hard drive as MBR, or GPT? – Cullub May 17 '18 at 15:12
  • So I can't use WinToUSB since I'm installing to a hard drive, not a USB stick. The hard drive is connected via PCIe. I downloaded WinToHDD from the same people and I'll give that a go as well. – Cullub May 17 '18 at 15:23
  • Ah, okay fair enough. My previous experience with this software successfully did the job with WinToUSB going to an external hard drive which i then removed from it's caddie and installed via PCie into a desktop computer. Hopefully the WinToHDD will work in the same way for you. – Myles May 17 '18 at 15:25
-1

I had a same problem. Installing Windows 10 32bit to an M.2 Samsung 970 EVO NVMe SSD. The solution to this is to install a Win 10 32bit driver (controller) for your SSD, during Windows Setup. That Worked for me.

First, make sure that the SSD on which you want to install Windows is the only drive connected to the PC (unplug the other drives).

Download your SSD driver, extract the content to a new folder and put that folder somewhere (in the USB installation media for example). The links for several 32bit SSD drivers are availaible in this forum page: https://www.win-raid.com/t29f25-Recommended-AHCI-RAID-and-NVMe-Drivers.html Make sure to expand the spoilers to see the details. If a download for your SSD driver isn't available in this forum, I'd suggest to ask the guys out there for help.

Enable the Legacy Bios Support.

Launch Windows installation, when at drive selection step, open the Command Prompt (by pressing Shift+F10). Type diskpart and hit enter. Type list disk and hit enter. Type select disk x and hit enter. x is the number given to your SSD drive by the previous command list disk (x will most likely be a 0). Type select disk x and hit enter. Type clean and hit enter (a message should appear saying that diskpart successfully cleaned the drive). Type again select disk x and hit enter. Type convert mbr and hit enter (a message should appear saying diskpart successfully converted the drive to mbr). Close the Command Prompt.

While at that same step (drive selection step for Windows Installation process), click on Load Driver then on Browse. Locate the folder that contains the driver and let Windows Setup install it.

The message that says Windows can't be installed on that SSD should not appear after that and Windows Setup is ready to go.

Here is another thread about this case (please see answer #8): https://answers.microsoft.com/en-us/windows/forum/all/windows-10-32bit-on-m2-nvme-ssd/718a26d2-3622-4af1-a14d-063f16d89ae8

Best.

  • 2
    Why must Legacy Bios support be enabled when Windows 10 supports 32-bit UEFI kernels? Seems like you are unnecessarily suggesting the use of MBR when it isn't required. – Ramhound Jan 30 at 18:45
  • Hi and thanks for the comment. What you mentioned is out of my knowledge ATM. Maybe it's not required at some point but it does work and provide a working solution to this problem. If you're sure about what you said, please add a reply about it for the public interest. – HelperX Feb 1 at 12:44
  • This is your answer, you will have to determine, if it’s necessary to actually enable Legacy Mode. – Ramhound Feb 1 at 18:21
  • I will for sure once possible. It's in my to do list. – HelperX Feb 1 at 21:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.