0

I am running Fedora 28 and am attempting to disable the user list in GDM (as the machine is domain joined, this is undesirable). In CentOS 7 this is as simple as putting a file named "00-login-screen" in "/etc/dconf/db/gdm.d/" with the contents:

[org/gnome/login-screen]
disable-user-list=true

In this case, there is no "gdm.d" directory. Creating it, and then putting the file in the directory does not work. I've seen elsewhere that a file needs to be created in "/etc/dconf/profile" called "gdm", but I have created this file with the contents:

user-db:user
system-db:gdm
file-db:/usr/share/gdm/greeter-dconf-defaults

and it makes no difference.

Has the procedure changed that substantially in Gnome 3.28.2 compared to 3.22.2?

EDIT: This problem now occurs in CentOS 7 as well, likely due to a Gnome update.

  • Sincere apologies for going totally off-topic, but 'No GDM' [Gina X Performance] was a huge underground euro dance floor hit in the early 80's... & now I can't stop singing it ;-) – Tetsujin May 17 '18 at 19:20
  • 1
    @Tetsujin, yes it's making it rather harder to Google this than it should be. :P – thunderbird32 May 17 '18 at 20:03
0

Navigate to /usr/share/gdm/dconf , where you'll find a file called 00-upstream-settings ; Make a copy of it and give it a higher numbered prefix (e.g. from 00 to 90). The settings are pretty self-explanatory.

If I'm not mistaken, it could be that the name of the corresponding setting has changed in the meantime, but adding disable-user-list and setting it to false should work anyway. Don't forget to run dconf update from your terminal to make the changes take effect.

Greets

| improve this answer | |
  • The directory /usr/share/gdm/dconf also does not exist. The only directories I have in the /usr/share/gdm directory is: autostart,greeter, and env.d. 00-upstream-settings only exists in the directory /etc/dconf/db/ibus.d/. – thunderbird32 May 17 '18 at 19:50
  • @thunderbird32 I'm sorry, I've just realized that we have different Gnome versions (I have 3.28.1-1) so on my machine it worked ... Some time ago I had some problems logging in with 'light-dm', after which I switched to 'gdm'. In the worst case, another login manager maybe could also be an option ;-) good luck – Joey May 17 '18 at 21:52
0
su -
mkdir /etc/dconf/db/gdm.d && chmod 0755 /etc/dconf/db/gdm.d
cat > /etc/dconf/db/gdm.d/00-login-screen <<EOF
[org/gnome/login-screen]
disable-user-list=true
EOF
touch /etc/dconf/db/gdm && chmod 0644 /etc/dconf/db/gdm
dconf update
| improve this answer | |
  • Welcome to Super User! Although this may help to solve the problem, it doesn't explain why and/or how it addresses the issue. Providing this additional context would significantly improve its long-term educational value. Please edit your answer to add explanation, including what limitations and assumptions apply. Thanks. – fixer1234 Dec 28 '18 at 22:23
  • This does not fix the issue either, and in fact the only difference in this from what I did, is creating a blank /etc/dconf/db/gdm. It current versions this file already exists, so this isn't particularly helpful. – thunderbird32 Jan 4 '19 at 14:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.