2

I need to delete Russian language pack, but in Language settings 'Remove' button is not highlighted. When I try removing it with lpksetup.exe /u command in cmd it says 'Language is the system language' and does not allow to do anything with it, but the system language is set to Ukranian (I've tried switching it to different language and back again - did not help). If I try removing at least keyboard layout in Windows registry (HKEY_USERS\.DEFAULT\Keyboard Layout\Preload\), it does not remove it and the key appears again in registy. Also I find it strange, that in Control Panel there is no Language settings, there is only Clock and Region in this section. UPDATE: Windows 10 Pro, Version 1803 (Update was installed today).

4
  • Language packs can now only be installed and removed through the Settings UWP application. What I suspect is the problem is, the language pack you want to remove, is from the previous build and thus needs to be reinstalled before it can be removed. You might have to revert the previous version of Windows, remove the language, then install 1803 after you do that.
    – Ramhound
    May 18, 2018 at 11:13
  • When you performed lpksetup.exe /u did you specify which language pack you wanted to install, because if you did not specify the Russian language pack, it assumed you wanted to remove the Ukrainian language pack. What was the exact command you ran?
    – Ramhound
    May 18, 2018 at 11:19
  • @Ramhound I've ran lpksetup.exe /u and 'Install and Uninstall display languages' window appeared, there were 3 languages listed (English, Russian and Ukrainian), if I select Russian it says - 'Language is the system language'. Should I try running 'lpksetup.exe /u ru-RU'? May 18, 2018 at 11:37
  • I don't know the correct 5 characters for the Russian pack. I do suggest you specify the language pack you want to remove when you run that command though. Of course my suggestion of reverting back to the previous version, remove any language pack and keyboard layout you don't want, might be the best solution. Windows has never really supported having a language version installed, then performing an upgrade to a different language version, I suspect you have ran up against an edge case.
    – Ramhound
    May 18, 2018 at 11:44

3 Answers 3

3

I ran into the same problem. Installed an unwanted Windows 10 display language by mistake, then could not remove it. It was not showing up in the list of languages in lpksetup.

It took a while to figure it out, so hopefully it helps others and the future me.

First, you need make this unwanted language the Windows's current Display Language. That can be done in the Language settings (Win+I and type Language). Then log out, log back in, run lpktool from the admin command prompt, select Uninstall and the language should be listed as available for uninstalling. Don't uninstall it just yet.

Switch back to your desired display language (e.g., en-US), log out/in, run lpktool again and now uninstall the unwanted language.


Updated for Windows 10 v2004 (build 19041.x), where apparently there is no way to remove a language pack via UI once it's been installed in the Windows Store app.

In the Admin PowerShell, run:

Get-AppxPackage -allusers *LanguageExperiencePack*

Find the desired language pack to remove, e.g.:

PackageFullName : Microsoft.LanguageExperiencePacken-GB_19041.1.2.0_neutral__8wekyb3d8bbwe

Remove it:

Remove-AppxPackage -AllUsers -Package "Microsoft.LanguageExperiencePacken-GB_19041.1.2.0_neutral__8wekyb3d8bbwe"

Finally, just in case, run lpksetup /u and clean up unwanted language packs there as well.

3
  • Related: superuser.com/a/1540185/246232
    – noseratio
    Apr 9, 2020 at 5:06
  • I tried this for removing the "qaa-Latn" language following this, but it doesn't appear as an option for the Windows display language, I don't have any 'lpktool' command, and 'Get-AppxPackage' returns only one language package, which is not the one I want to remove.
    – Joe
    Jul 8, 2020 at 9:41
  • @Joe, sorry that didn't solve the problem for you, but I don't have any other ideas. lpktool is gone with v2004, lpksetup is still here, but it won't help because you only have 1 language pack anyway.
    – noseratio
    Jul 8, 2020 at 10:20
3
  1. Install the language pack you need/want your PC to be in. (this can be done in language and region settings)

  2. Open command prompt in admin mode.

  3. Type lpksetup /u Into cmd prompt and you should see a window like this: https://i.imgur.com/qwltu8F.png

  4. Open Regedit in admin mode, then go to: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Nls\Language

  5. Find the language code of the language you installed on this webpage: https://msdn.microsoft.com/en-us/library/cc233982.aspx

  6. Edit the Default and InstalLanguage values to your preferred language value, For English-US the value is 0409

  7. Restart your PC.

  8. Open command Prompt in admin mode again and enter lpksetup /u. This time your preferred language will be set as the system default.

  9. Select the language you didn't want and remove it. Your PC will need to restart again and you are all set.

1
  • With over 20 similar questions (superuser.com/…), your answer is the only one that worked for me. Thanks much! Nov 1, 2021 at 13:31
0

try this in PowerShell, run as administrator and then type:

Set-WinUserLanguageList en-US

It will remove all languages, then install in settings any lang that you need

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.