6

Name says it all. Taskbar is set to auto-hide, taskbar does not auto-hide, obviously I want it to auto-hide. Some program is keeping it from doing that. Sometimes I find the culprit quickly if the developer made something like the icon or app flash but sometimes I search for a while before I find it.

(And no, this, this and this are not answers to "what program," they are cop-outs when you can't fix the problem. I already have an autohotkey to kill and restart explorer but it's annoying.)

Bonus points if you know the windows message to trap to prevent a program from doing it because my next step is creating an open source app that blocks it and auto-generates an email to the developer every time it happens.


Edit: I'm presently looking at poking around with the SHAppBarMessage function when I get time so if anyone has already tried that, a success/fail report could save me time.


Edit 2:

Still, this ridiculously persistent problem keeps popping up and sticking around after all these years. My current favorite workaround is pinning an Explorer re-launcher to the taskbar:

  1. Create a bat file containing taskkill /F /IM explorer.exe & start explorer Create bat file
  2. Right click the bat and create a shortcut to it
  3. Right click the shortcut and edit it so that instead of {path to blahblah.bat}, it has cmd \c "{path to blahblah.bat}" ... (this is to circumvent Microsoft protecting you from putting what you want on the taskbar because they think you're dumb) Edit shortcut
  4. Drag your fancy new shortcut to the taskbar Winning Workaround
-1

From this article: https://www.ghacks.net/2017/04/29/windows-10-taskbar-not-hiding-here-is-the-fix/

The idea is to discover the underlying app that wants attention. Some apps or background apps do not have an icon displayed, therefore no indication is visible.

Solution: Enable all icons for a short time to see the icon that is wanting attention.

Quote: Start by opening the Taskbar preferences again. This is done with the keyboard shortcut Windows-I, and navigating to Personalization > Taskbar in the Settings application.

Locate and click on "select which icons appear on the taskbar" under notification area.

Select-icons-taskbar

I recommend that you check the "always show all icons in the notification area". The reason for that is that you get a good overview of all icons, and can identify the culprit easily this way.

| improve this answer | |
  • It might be better if you quoted less of the rambling discussion of why the problem occurs andÔÇ»focused more on the solution. – G-Man Says 'Reinstate Monica' Aug 10 '19 at 1:03
  • Thanks @G-Man. Please give credit to Martin Brinkmann for his thorough explanation and detailed answers for this irritating issue. – user1864803 Aug 13 '19 at 18:08

Not the answer you're looking for? Browse other questions tagged or ask your own question.