Somehow my Windows 10 laptop stopped getting the correct DNS servers sent from Wifi networks. It somehow locked and won't accept whatever DNS IP comes from DHCP. I have no idea how/why, and I tried everything to fix. Any thoughts?

Tried the Wifi while sitting at a Starbucks, the office, or the Apple Store, it always put as the DNS server instead of the correct DNS IP supplied by the DHCP router.

I tried this under Command Prompt (run as Administrator), still did not help:

netsh winsock reset
ipconfig /flushdns
ipconfig /renew

Also rebooted several times, turned Wifi on/off, deleted known Wifi networks... nothing works. I also tried manually setting the DNS IP when at a known Wifi place, which works, then I set back to obtain automatically, and it goes back to stuck on

For example, check out ipconfig /all output from a Starbucks, it incorrectly says as the DNS:

Wireless LAN adapter Wi-Fi 2:
   Connection-specific DNS Suffix  . : home
   Description . . . . . . . . . . . : Intel(R) Centrino(R) Advanced-N 6205 #2
   Physical Address. . . . . . . . . : 60-67-20-12-34-56
   DHCP Enabled. . . . . . . . . . . : Yes
   Autoconfiguration Enabled . . . . : Yes
   Link-local IPv6 Address . . . . . : fe80::2d12:3c21:1234:5678%23(Preferred)
   IPv4 Address. . . . . . . . . . . :
   Subnet Mask . . . . . . . . . . . :
   Lease Obtained. . . . . . . . . . : Friday, May 18, 2018 9:30:43 AM
   Lease Expires . . . . . . . . . . : Friday, May 18, 2018 10:43:47 AM
   Default Gateway . . . . . . . . . :
   DHCP Server . . . . . . . . . . . :
   DHCPv6 IAID . . . . . . . . . . . : 308307744
   DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-1D-D4-7C-E7-3C-97-0E-12-34-56
   DNS Servers . . . . . . . . . . . :
   NetBIOS over Tcpip. . . . . . . . : Enabled

I have the Wifi interface set to pull DNS from DHCP, see screenshots below.

Wifi Network Adapter Properties

Wifi Network Adapter Properties

  • What is on the WINS tab?
    – Moab
    May 18, 2018 at 15:13
  • 1
    I went ahead and uninstalled/reinstalled the Wifi driver while connected to the Internet another way (tethered to my phone) so I could re-download the driver, and that seemed to fix the problem. Sorry I did not capture the WINS tab, but don't recall seeing anything there when I checked. May 18, 2018 at 15:19
  • You can and should answer your own question using the "post your answer" button.
    – Moab
    May 18, 2018 at 15:21
  • Also seeing this on Windows 10 on the last few months. Not easy to resolve. There shpuld be an answer that does not involve reinstalling the driver
    – Otheus
    Oct 22, 2018 at 10:33
  • @Otheus I agree... wish I knew the fix. Otherwise, I suggest keeping a copy of your Windows laptop's Wifi driver on the laptop itself (or quickly accessible from a USB flash drive), so if it goes crazy with DNS locking, uninstall then reinstall the driver. Dec 20, 2018 at 22:59

5 Answers 5


This is an older question but I just wanted to add my answer here because this question came up when I was searching for an answer and it pointed me in the right direction.

If your nameservers point to something that you once manually entered in the TCP/IP properties, this setting is cached in the registry under


where {*interface-UUID*} is a unique ID that is assigned to the different interfaces on the local machine. ProfileNameServer is a REG_SZ string that contains a space-separated list of IP addresses of the nameservers to use. This appears to override the DhcpNameServer string, which is of the same format.

I cleared the ProfileNameServer string and the interface in question used what was in DhcpNameServer instead, which solved my issue.

  • 1
    Thanks!! I will try this next time it happens. Jul 27, 2019 at 18:31
  • 5
    In my system (Windows 10, build 1903, version 18362.592) the DNS setting is stores under the NameServer registry key instead of ProfileNameServer (which doesn't exist). Jan 21, 2020 at 14:23
  • 1
    I'm on 1903 Windows Pro and my Wifi adapter still uses ProfileNameServer although every other adapter uses NameServer. This procedure worked and should be the accepted answer.The effect was immediate - I cleared the value and ipconfig/all immediate showed the correct DNS servers.
    – Deepstop
    Jul 10, 2020 at 11:42
  • 1
    Also works on 20H2. Was struggling for months with this problem & had to set my DNS manually depending on which network. Thanks for the tip!
    – wouter205
    Apr 8, 2021 at 5:49
  • 1
    I wanted to thank you: Turns out I was already here (perhaps years ago) because that up arrow already was blue. Many thanks, second time.
    – Alex
    Nov 17, 2021 at 17:22

Frustrated, I decided to try uninstalling/reinstalling the Wifi driver. Did by:

  1. Pre-downloaded the network driver from the Drivers page of my laptop maker (Lenovo), or having an alternative way to access the Internet such as tethering through my phone, so I could download the driver.

  2. Device Manager, Network Adapters, right-click the wifi device, Uninstall Driver.

  3. Used the downloaded driver from my laptop manufacturer, re-installed, rebooted. Now the Wifi DNS works fine wherever I go.

I tested at 2 wifi locations (coffee shops) so far, works fine now.

Note that some public Wifi networks at coffee shops & libraries have what's called a "Captive Portal" which requires use of the DNS supplied via DHCP. They will not work with a public DNS or fixed DNS locked in to the Wifi interface. At such locations, new devices that join the Wifi network are redirected to a page to accept the Terms & Conditions (or log in) before being granted access to the Internet. This is why my Wifi stopped working at coffee shops, and would not help to use a fixed DNS like

  • THANK YOU!!! For what it's worth, just uninstalling the device and reinstalling it worked for me. Jul 28, 2019 at 15:46
  • Sure thing. Also people may have luck following 4AM's solution below, by editing the registry. Reinstalling the driver, though, may be easier if you remember to keep the driver installer program on the laptop. Jul 29, 2019 at 16:13
  • It was a very annoying issue! To clarify, I didn't need to re-install drivers. I Uninstalled the device in Device Manager, and then re-scanned device manager for changes. That's all. Windows Just reinstalled the same driver again to fix it. There must be a cache somewhere on the system. Jul 30, 2019 at 8:44

We just changed servers - meaning the old DHCP-server is shut down, and there is a new DHCP-server. Simultaneously, we changed DNS-server. I saw the same thing here - Windows 10 hangs on to the old DNS and no matter how many dhcp release/renew or reboots or whatever - keeps the previously used IP.

I solved the matter by doing regedt32 and manually changing the values (just search for that wrong IP (in your case The key is called DHCPdns or something similar.

I am still a little puzzled as to what the error is caused by. Since we kept the DHCP range the same, I figured it was just the matter of the PC asking to keep the IP it had already been assigned (and thus keeping all the other parameters when the DHCP-server says "yes, fine").


My situation was slightly different but using this article helped me resolve my issue: https://answers.microsoft.com/en-us/windows/forum/all/your-computer-is-trying-to-use-a-dns-server-that/c8f9e28e-7bb9-439c-bfac-3a097ddc2dfd?auth=1

I was able to determine that although my ipv4 adapter settings for DNS servers was correct, DNS lookup (nslookup someserver) was failing because it was first using the ipv6 DNS server adapter lookup and failing. Changing the ipv6 adapter settings for DNS server solved the issue for me.

Note that while the answer in the Microsoft forum had useful checks and tests, it was the MiniTool.exe that provided the information that led me to the answer. I resisted trying the MiniTool.exe at first but appears to only collect all your Windows information and output into a single text file that makes it easier to review the tcp/ip and DNS information from your machine.

Hope this helps someone in the future.


Normally, some DNS servers are publicly available for private or commercial use. For example, Google has a open DNS server available on Use this IP-address as your default DNS server instead of it being obtained automatically.

  • This is true that public DNS are available, but it will not work at coffee shops or with routers that require a login. For example, modern routers at public Wifi places (especially coffee shops and libraries) use their own DNS to redirect browsers to a specific webpage to agree to terms & conditions (or log in with a password) before granting access to the Internet. In those cases, using a public DNS will block access to the Internet regardless of being connected to the Wifi until the client's browser is redirected (via DNS) and agrees to the terms of use (or logs in). May 30, 2018 at 15:57

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .