1

We are running a Windows 10 pro 64bit computer next door, in French GUI and with more than 10 users. I am in charge (administrator user) but working in several places.

A few days ago, we started getting messages, when requesting to shut down: "Une autre personne utilise ce PC. Si vous arrêtez le PC maintenant, cette personne risque de perdre les données non enregistrées."

I believe (from a web-search) on a Windows with English GUI it would say this: "Someone else is still using this pc. If you restart now, they could lose unsaved work."

Under normal circumstances, I would consider this a very helpful and friendly message.

BUT: Why is there another user logged in, after she did a full shut down and after I (a day later) did a proper reboot? And how can any user (ever) be logged in after a re-boot if all users have a proper password and nobody has opted out of anything? We each use our passwords every time we boot and work.

edit1: I had a helpful comment and I entered netplwiz into the PowerShell: The "accounts window" had the following box unticked, which surprised me: "Les utilisateurs doivent entrer un nom d'utilisateur et un mot de passe pour utiliser cet ordinateur." (this means that users did NOT need to enter a user name and pw; and of course I ticked the box. So from now on pw will be enforced (again). Maybe this will fix our issue, I will do some testing now and will report here. end-of-edit1

When (after getting this new message and before shutting down (obviously)) I click on my avatar (which comes up when I click my start button) I can see in the list of users, that indeed Windows believes that one other user is logged in. It is the last user who was logged in before the shut down and the reboot.

This has happened for different users being followed by another user, so seems to be a system-wide problem, not limited to a certain userA - userB sequence.

For information: We have opted in the power settings to always do a full shut down, not a quick shut down, because we are in Africa and often have power issues or generally want no side-effects from "shortcuts".

When I opt to "ignore" this warning and go through with the shutdown, it looks and feels like a normal shutdown.

When I shut down and reboot and log-in twice under my own user, then I no longer have any other "ghost users" along. (this could be our work-around, but you will agree that we hope to understand and fix the issue)

The computer in question was very recently updated (via Media Creator Tool - and .iso option) to Windows 10 Version 1803 build 17134.48. I believe that the problem started a few days before the update, when we were in a video project together.

Another recent "change" that comes to mind: We just purchased and installed (before the Windows 10 update even) a Seagate "Backup Plus Hub" which is an external 3,5" 6TB HDD in its own case, with a USB3 connection to this computer. For the last ten days or so, we have always kept it connected and several users worked a lot on video projects on this drive. So the external files show up as an E:\ drive and do not "belong" to any specific user I believe. Normally this should not give us "haunted user log-ings", but just to be complete.

Why is this important to me: Seems that in our video project (using Shotcut and some other tools) there is one Shotcut project which is very messed up. And it keeps diagnosing itself as "damaged" and it keep recovering itself. I also use Shotcut on my own computer and have never seen such "damage plus recovery". So this could be one specific problem, which results from Windows either not un-logging users at shutdown time, or from unwanted background-logging-in-again of absent users. I hope we can fix the video-project problem, once we have fixed the Windows.

Thank you.

  • 1
    +1 Nice detailed writeup. Question: Is it possible that you have set Windows to automatically sign in to your account at startup using netplwiz, but may have entered the password incorrectly or changed the password or computer name afterwards. This could cause what you are seeing. If you wanted to automatically sign in, then go through netplwiz to set it up again. If not, then make sure the "Users must enter a user name and password to use this computer" box is checked. – harrymc May 18 '18 at 15:40
  • @harrymc I hate all things automatic and I have never seen netplwiz but it is possible. I have NOT changed the computer name. Typos in pw are frequent because of our many different keyboards and languages in our team. I want to enforce that all users sign in by password and I believe those involved in our recent problems are doing so. Still thank you. I typed netplwiz into my Powershell and got a helpful window. Will check on affected computer next time I go to the office. Thank you. – Martin Zaske May 18 '18 at 15:59
  • @harrymc I appreciate this forum very much. So because of your comment I have run over to the office and am now at the affected computer. I did look and made edit1 above. Will now do some testing with different user log-ins and and reboots (I got all pws, as I am admin) and will edit my question more. – Martin Zaske May 18 '18 at 16:25
  • 1
    Cortana offers the ability to "complete setup" after restarting for a patch. There have been questions about this here recently, but I cannot find the questions. But check in the Cortana settings to see if this feature is enabled. – music2myear May 18 '18 at 16:29
  • @music2myear Thank you. We are not using Cortana but I just took some time to find the settings. (I have run over and am not at that computer). I found some creepy stuff activated about this new Windows History - and I have disactivated all that. Funny enough, when I updated my personal machine (German) I had a long dialog-thing which I had never seen on this French machine. Maybe that was the "complete setup", where I could opt-out a lot of unwelcome "tell MS everything about your work"... I can reproduce the error and will test whether your idea has helped. – Martin Zaske May 18 '18 at 16:53
-1

Turns out, it is yet another surprising "feature". You can quickly see if your machine is affected: Open the Task Manager (lowest option on CTRL+ALT+DEL) and open its tab called "users". If you see more people, not just your own user-name, you are having this too.

Note that the other user is using some of your computer's memory and sometimes processor-power.

The explanations are in those two threads:

Here the problem is discussed from the victim's perspective

Here we read about "it is a feature"

In a brutal summary this is our problem:

Autolaunch = "Yes the system is now designed to do all this automagically and to recover the open apps at next reboot." You are getting this? My team-mate has shut down the machine (and maybe travelled to another country, or whatever). And when I next boot, some of his apps are being "autolaunched" again, using the system for nothing!

Now having found the problem, I also found a solution: With this command, each user can do a "real shutdown" or a "full shutdown":

shutdown -t 0 -s

One helpful user on tenforums shares how he turned this into a clickable item in his start menu (right hand side). Took me a while to figure it out, so here with more detail:

  • click on a free space on your desktop or in some folder you own

  • select "new" ... "shortcut"

  • in the little window entitled "Create a new Shortcut (or similar in English)" enter the command directly into the box where the cursor is blinking (where you normally put a path to some app)

    shutdown -t 0 -s

  • click next and give it a good name like "My total shutdown"

  • click finish

  • now your shortcut got created and you can right-click on it and call up its properties

  • here you can assign a nice meaningful icon, if you want and hit OK

  • After OK you can right-click again and click on pin to Start-Menu if you want (so you do not need to memorize "shutdown -t 0 -s"), it will be on the right hand side somewhere among your apps

If you shut down with this "-s" option the (new) default option "-g" will be overridden and those unwanted other-user-apps will not be autolaunched on next boot by another user.

You can enter "shutdown /help" in your Windows Power Shell or Command Window and read more about the options; it has helped me. If you find out how to call all the default options on a specific machine, please edit here or write a comment.

If you are wondering, like me, "what are those apps that get re-launched for my team-mate?": I do not know. In my first link, user Bree is saying it has to do with being either an app or a process if they come up again automatically or not.

I suggest you go to your Windows Settings and then to Confidentiality and then to Apps-in-background (or similar in English), you might be amazed about all the stuff which is authorized to run without you ever seeing it. It takes several minutes to bring a new-user confidentiality options to something reasonable by deactivating a lot of stuff. My guess is that some of those things get autolaunched on re-boot, depending on what the user did last.

  • 1
    My answer might not be well written, but it gives us a working solution for this problem. I can accept that veteran users feel a need to mark-down according to their own reasoning. Still it would help me please, if you would comment why. Or better, please write a better answer, so that I can learn from your example, being new here. Thanks. – Martin Zaske May 24 '18 at 12:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.