1

My system is Debian Linux. My new 4k UHD display only uses 1920x1080 by default.

1 Answer 1

2
$ cvt 3840 2160 19
# 3840x2160 18.98 Hz (CVT) hsync: 41.48 kHz; pclk: 205.75 MHz
Modeline "3840x2160_19.00"  205.75  3840 4008 4400 4960  2160 2163 2168 2186 -hsync +vsync
$ xrandr --newmode "3840x2160_19.00"  205.75  3840 4008 4400 4960  2160 2163 2168 2186 -hsync +vsync
$ xrandr --addmode HDMI-1 "3840x2160_19.00"

Then I can select 3840x2160 in display settings. Higher refresh rates don't seem to work, so things are not displayed very smoothly, especially mouse pointer and movies.

Even better:

Download http://www.riscosports.co.uk/cvt.zip

(Compile source code with gcc -o cvt -lm cvt.c)

Calculate the modeline with

$ ./cvt  3840 2160 24 -r -x

  # 3840x2160 @ 24.00 Hz Reduced Blank (CVT)
  #   field rate 24.00 Hz; hsync: 52.44 kHz; pclk: 209.75 MHz
  Modeline "3840x2160_24.00_rb"  209.75  3840 3888 3920 4000  2160 2163 2168 2185  +HSync -Vsync

Then I can select 3840x2160 at 24Hz in display settings.

I filed a bug for Debian cvt not supporting reduced blank at refresh rates other than multiples of 60Hz: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=899066

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.