1

I was deleting some ancient passwords in "Saved Passwords" in Google Chrome and inadvertently deleted very important passwords, (like my Google account login for one). When I try to log into my Google account, it doesn't ask if I want to save it again.

I've set the settings to "Offer to save Passwords", but it does not "offer" anymore. Is there a way to just insert a username/login and password into the "Saved Passwords" section, or force it to ask?

UPDATE: as I was registering on THIS site, Chrome asked to save the password, but it still won't ask to save the password for my Google account; tried several times.

  • Please make the title summarize the actual question. – Arjan May 19 '18 at 7:10
0

By default chrome doesn't offer to save your Google credentials for security reasons. You can still force save by clicking on the icon to the right of the URL.

If you save your Google account in Chrome, I recommend activating 2 step authentication. Also do not save your recovery email credentials.

  • 1
    The only icon I have to the right of the URL is a star to "Bookmark This Page" (on any page or site I pull up) – adraysr May 19 '18 at 8:31
  • @adraysr there should be a key symbol to the left of the bookmark star, if you haven't added the google domain to your list of "never save". – jiggunjer May 19 '18 at 10:41
  • 2
    Nope, there is no key symbol at all next to the bookmark star or anywhere in the address/URL line... and as I said in OP, I already had a google saved PW and I have nothing in the "never save" list. What I was doing was going down the Saved Password list and deleting old, old passwords to sites I no longer use, There were about 4-5 in a row above the google saved PW and I was clicking them one at a time, not paying enough attention and I went too far and deleted the google PW by accident... So here we are and my reason for asking this question Post... – adraysr May 20 '18 at 6:39
  • @adraysr The key icon appears for me once I type in a value in the password field (in the site I am having this same issue). It still doesn't ask me to save the password unlike before, but using the key icon method works. – georaldc Sep 10 '18 at 22:55
0

I had the same problem. Google / Chrome has saved every one of my Google accounts except the one I use most. After typing the password a ridiculous number of times, I had to fix it. Google Chrome help suggested changing the password might trigger it, but nothing, though it did result in achieving my goal some hours later. I also removed that account from the 'Never' list, and this too is essential. I went to many sites, but found no solution anywhere (until now when I was seeking somewhere to add my fix and each of the solutions, while they seem successful, requires a level of computer savvy.

Mine does not. Open settings, turn Sync off. Since your password isn't saved, it should ask you to verify your identity with your password to allow you to turn sync off. And then Chrome asked me if I wanted that password saved. I hope my easy fix works for others. It took me hours to fix. I'm not giving myself a face palm

  • 2
    I’m having trouble determining whether you have an answer to the question.  If you have found a procedure that gets Chrome to re-save a password, please list the steps, including any notes on how long you have to wait for things to take effect, but omitting the things that didn’t work, and how long and hard you had to search to find the solution. – Scott Mar 17 at 1:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.