0

In windows 10, I switch between a Greek Polytonic keyboard and a normal English QWERTY keyboard. I have an autohotkey script which swaps the left control key with capslock.

settitlematchmode, 2
#IfWinNotExist, ahkblock
capslock::lctrl
lctrl::capslock
#IfWinActive

However when I switch to the polytonic greek keyboard, for some strange reason autohotkey interprets my script to mean that I want the right alt button to function as a second caps lock key. This is unacceptable because I need to use that right alt button in order to combine iota subscripts with breathings and accents.

Do you know of any workaround or bug fix for this issue?

  • Just to be clear, the normal intended swap still occurs with the Greek, but in addition your Ralt is changed? – jiggunjer May 19 '18 at 6:42
  • @jiggunjer That's right – TheIronKnuckle May 19 '18 at 7:02
0

I ended up using an alternate method to swap control and capslock (I found a program that lets you change the key mappings in the registry directly - sharpkeys), and now I use Autohotkey to swap them back on the rare occasions that I need control to be in the bottom corner of the keyboard.

My autohotkey script now reads as follows:

settitlematchmode, 2
#IfWinExist, swapcaps
capslock::lctrl
lctrl::capslock
#IfWinActive

So if I need to temporarily swap the keys back to the standard layout, I just need to open a cmd window and set it's title to "swapcaps"

This isn't an actual fix for the bug, however it is a workaround and it works just fine. (Arguably even better than the original autohotkey solution, which was not flawless)

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.