I have googled this issue and tried every single solution that has come up.
All my computers' brightness controls have stopped working.
Some broke after the creators update, some broke after the latest update.
Some locked the brightness at minimum with the control grayed out and some give the option to change it but clicking it does nothing.

EDIT: Specs: PC#1: HP Compaq 8510w
Broke after Windows 10 creators update
I'm running the latest NVIDIA drivers, I tried going back one version and even tried installing the OEM drivers to no avail
Brightness on this laptop is locked at zero, even if I boot into Windows 7 and change the brightness it is set back to zero
Brightness function keys do nothing

PC#2: HP 6730b
Running latest Intel GPU drivers
Broke after Windows 10 update 1803 (latest)
Function keys do nothing, brightness appears to be at the value I set it before the update

PC#3: Gateway One ZX6980 (desktop)
Running latest Intel GPU drivers
Broke since release of Windows 10
On this one the option to change the brightness completely disappeared from the menu after the Windows 10 upgrade

Edit2: PC#4: HP 2000
Interestingly enough the function keys for brightness work on this laptop however the brightness control on the Side Bar and in the mobility center do nothing

My desktop is too bright and laptop is too dim now.
The Gateway desktop shipped with Windows 8.1 and the laptops shipped with Windows 7

Nobody seems to know a solution and posting on the Microsoft forums/answers only yelds the generic troubleshooting steps.

enter image description here

Don't mind the "activate windows". I tried a fresh install to no avail.

  • The two totally dissimilar computers having this same problem have exactly one common denominator which is their owner. You should find out what setting you are changing, or what incompatible app is installed, that causes it. How are we supposed to guess it from here? – harrymc May 29 '18 at 11:13
  • Apologies for not putting computer information, will do in a moment. for people saying it is me (the user) this is happening on a fresh of Windows 10 – David Scheiber May 30 '18 at 4:42
  • Check out PeteMosses's answer it worked for me. – Meintjes Nov 3 '19 at 14:29

Fixed by Microsoft as of yesterday in KB4284835:


Addresses an issue with the brightness controls on some laptops after updating to the Windows 10 April 2018 Update.

| improve this answer | |
  • just tested with pc#2 no dice, made sure update was installed by downloading it manually. Unfortunately still no brightness control. will test other laptops though. – David Scheiber Jun 15 '18 at 13:37

Windows 10 has several known problems with brightness controls, but it is still astonishing to have the same problem on two completely different devices.

This is a list of workarounds that worked for some people :

  • Restore power defaults
    In Control Panel > Power Options, click Change Plan Settings and then on Restore default settings for this plan. Do this for all your Power Plans.

  • Disable Adaptive Brightness
    In Control Panel > Power Options, for your active power plan click Change plan settings, then Change advanced power settings. In the Power Options dialog, expand Display and then expand Enable Adaptive Brightness. Set all of them to Off.
    These setting are worth a look if you have then : Display brightness, Dimmed display brightness and Enable adaptive brightness.

  • Disable the Intel Power Saving Technology
    This setting is found in your Dell or Vaio Control Center. For more info see this article.

  • Disable the BrightnessReset task
    Open Task Scheduler and in the left pane expand Task Scheduler Library. Navigate to Microsoft > Windows > Display > Brightness (if you have it). If you see on the right a scheduled task called BrightnessReset, double-click on it, choose Properties > Triggers tab > Edit, then disable it and see if it works for you. A reboot might be required.

  • Run the Power Troubleshooter
    You may access it via the Windows 10 Troubleshooters Settings Page or run the following command directly to bring up the built-in Power Troubleshooter

    msdt.exe /id PowerDiagnostic
  • Registry change
    Use regedit to go to the key
    If you see any items named KMD_EnableBrightnessInterface2 or MD_EnableBrightnesslf2, set them to zero and reboot.

  • Power troubleshooting
    For further troubleshooting of Power Plans, use the built-in PowerCFG command line tool.

| improve this answer | |
  • No dice, I even tried turning on adaptive brightness and putting my finger over the light sensor but it had no effect – David Scheiber May 30 '18 at 13:45
  • Could you post the output of powercfg -energy? – harrymc May 30 '18 at 13:57
  • sure thing,drive.google.com/open?id=1Xq9oDqnRbsygueZ8EzhfJFmEe-fA3QiR I'll put the results for each pc in their folders – David Scheiber May 30 '18 at 14:10
  • Something to note is the device driver error on PC#2 is because I don't have the HP driveguard drivers installed, you know for the shock sensor that stops the drive if you drop the laptop. I never bothered installing those drivers since I usually find such features more of an inconvenience since when using your laptop on the go it tends to stop the hard drive at the slightest bump – David Scheiber May 30 '18 at 14:15
  • In the energy report for PC#1 and 2 I see this: "This computer does not allow Windows to automatically control the brightness of the integrated display. Installing the latest system firmware (BIOS) may resolve this issue". Nothing said for PC#3 and an ok for PC#4. A wild guess is that the latest Windows 10 requires a more advanced BIOS for brightness control. But no idea why it only works partially for PC#4. – harrymc Jun 1 '18 at 11:21

I had the same issue turns out it wasn't a display driver issue at all it was just the monitor driver. Go into device manager then under monitors check what your monitor says mine said PNP Monitor Standard I had to update the driver and use the manually select from a list option then select Generic PNP Monitor after that everything worked like before.

| improve this answer | |
  • This worked for me, thanks. I've been looking for a solution for quite a while now. My laptop is a HP EliteBook 840 G5 for those wondering. – Meintjes Nov 3 '19 at 14:28

On my HP Envy laptop, I realised that after updating windows, sometimes the monitor in Device Manager gets disabled automatically. I enabled it and immediately the brightness changed.

Right-click on "This PC", click on "Manage", choose "Device Manager" from the left-hand menu. Under "Monitors", right-click on "Generic PnP Monitor". If the device is disabled, you should see an "Enable" option. Click on it and the problem should be solved.

| improve this answer | |

For the laptop, try the Windows Mobility Center, which has several controls on it, including one for brightness.

Two ways to access:

  1. Right click the start button, and click Mobility Center
  2. Press the Win + R shortcut keys together on the keyboard to get the run box, type "mblctr" (without the double quotes), and hit enter.

This won't work on a desktop, however, unless... you unlock the feature.

Follow the directions here: https://winaero.com/blog/mobility-center-desktop-windows-10/

In short: Open notepad and save a file named MobilityCenterEnable.reg

In the notepad, paste:

Windows Registry Editor Version 5.00


Save the file, and double-click the file to run it.

Now you can run the Mobility Center on your desktop, and there would be a brightness control there also.

| improve this answer | |
  • No dice, give me a moveable brightness slider however moving the slider has no effect on brightness (on all 3) unfortunately – David Scheiber May 30 '18 at 13:42

I don't know if you have fixed the issue, but as for me, the problem was that my high contrast theme, which I accidentally tried, saved to my Microsoft account. No matter what I did(reformat, re-install drivers) it always reverted back to a high contrast them at start up. This was because my Microsoft account was auto applying the theme at sign in, then wallah! High contrast is on even with a fresh install of windows.

In the 1803 update there is no option in the(settings->ease of access->high contrast) theme of "None" to apply to your Microsoft account, so that it might save to the Cloud/One Drive or whatever it backs up too. That option was removed from 1709 version.

After 6 hours with Microsoft support (with an out come of "you need to call your manufacturer, you probably have a hardware malfunction." or "your Nvidia Drivers are not yet updated for the new 1803 update") I got them to set me up with a USB drive with the 1709 version. Once I was on that version of windows, I went to high contrast themes, selected a theme, clicked on the apply high contrast theme button (this was so it saved to my Microsoft account), then selected the high contrast theme of "none" and clicked apply. Now it was saved to my Microsoft account.

I still had to restart my computer 3 times for the "none" high contrast theme to load at start up. I suppose it took that long for it to save to my Microsoft account. Once that was done, I turn off sync settings to Microsoft account in the settings->updates, I think.
I believe, but do not know, that the 1806 update turns "sync themes to Microsoft account" back on by default.

This reverted my colors back from neon, having to ware sunglasses to use google, to the nice Matted but full colors that I was used too.

Hope this helps.

| improve this answer | |

The only things that have worked for me are:

  1. Changing the FeatureTestControl entry in \Computer\HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\Class\{4d36e968-e325-11ce-bfc1-08002be10318}\0001 (some find it in 0000) of the registry to fb20 (also try f008 if needed) and rebooting.
  2. Opening the Device Manager, uncollapsing Display adapters, disabling Intel(R) HD Graphics 530, and reenabling it.

#2 only worked temporarily for me, so hopefully #1 will stick (I only just did it, so it's too soon to say).

Edit: #1 only worked for a few days. #2 seems to work for weeks, so I'm sticking with it for now.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.