I would like .txt files to open with Notepad++ by default in Windows 10. I have found the options to change file associations but there is no option to specify custom programs. Here's a screen shot:

enter image description here

How can I make Notepad++ default program for .txt files?

  • 2
    Are you sure that Notepad++ has been installed using setup.exe and was not just extracted from .zip archive which is a.k.a. "portable installation" ? You can associate file type only to the applications installed using setup.exe – maoizm Oct 25 at 13:04
  • @maoizm I use portable versions of Notepad++ and I have no problems associating it as the default for .html, .css, .js, etc. filetypes – InterLinked Nov 1 at 20:08
  • 1
    @InterLinked well, thanks, this is really helpful as I use a lot of portables and for sure last time I tried it didn't work – maoizm Nov 2 at 6:10
  • 1
    Possible duplicate of SSMS wont give up file associations – Scott Nov 11 at 17:46
up vote 10 down vote accepted

Follow the below steps

  1. Right click any .txt file and click

Open With > > Choose another app

  1. In the opened window click

More Apps

enter image description here

  1. Scroll to bottom and click

Look for anther app on this PC
enter image description here

  1. Navigate to install location of Notepad++. Default is

C:\Program Files\Notepad++

  1. And select "Notepad++.exe"
  • 1
    Its strange that you can't do this through the settings panel. Seems like a mistake to me... Thanks for the info. – CiaranWelsh May 20 at 11:06
  • 11
    Just don't work, it changes back to notepad immediately. – Daniel Hári Oct 16 at 14:46
  • I had to install Notepad++ Fork from Windows 10 store: microsoft.com/en-us/store/p/notepad-fork/9plhc123mqwt to make all mentioned methods work:/ – Daniel Hári Oct 16 at 14:59
  • Sadly, it only works for most - but not all - files. I can, for example, not re-associate *.log files. Which is incredibly annoying... – Structed Dec 7 at 20:00
  • 1
    I'm trying to set vim as my default editor for .txt files. I've been using this exact method for ages, but for some reason it seems to be broken on 17134 of Win10. – JBarberU Dec 11 at 16:56

How can I make notepad++ default program for .txt files?

  1. Run Notepad++ as an Adminstrator

  2. Menu > Settings to open the "Preferences" dialog

    • Click "File Association"

    • Click "Notepad", then

    • Click ".txt". then

    • Click "->" to register notepad++ as the program to edit .txt files:

    • Click "Close"

enter image description here

  • 5
    Doesn't work in Windows 10. Not sure why. – user477799 May 20 at 10:50
  • 3
    @EUserNameError You have to run as Admin. Answer updated. – DavidPostill May 20 at 11:51
  • 2
    Tried that. Doing so even prompts the other non-admin users if they want to update their file association. But the very first time that non-admin user visits the Preferences dialog box, his/her choice gets null and void. And I really hate being called by each of the 133 computer users when they want their admin to update their file association, especially when it is to no avail. So a -1 for needing admin privileges. – user477799 May 20 at 11:56
  • 1
    Unlike the chosen answer, this one actually works! I'm betting this got broken in a Windows 10 update, because I always used to open txt files with notepad++. – Luigi Plinge Nov 3 at 15:35
  • 1
    @pzkpfw - while true in general, something in a recent windows update appears to have broken the "normal" OS methods, for some users (including me). Hence this answer is a useful alternative. – ToolmakerSteve Nov 4 at 11:18

With Windows 10 (Oct 2018) this worked for me:

  • Open Notepad++ as an administrator and then follow the steps posted by DavidPostill above

then

  • Go through the normal Windows process of right click "Open With >" > "Choose another app" and click the "Always use this app to open .txt file" box.
  • this worked for me. Double clicking on the file in Windows Explorer works as well instead of "Open With". – fpiette Oct 29 at 8:49
  • only this worked for me (WINDOWS 10) – T.Todua Nov 23 at 12:24
  • As of 12/4/2018 this method worked. One part or the other did not on its own, but together it did the trick. I'm guessing the most recent Windows update broke the Default Apps thing, which is kind of obnoxious. NOTE: Once the steps are done, your txt files should take on the Notepad++ icon, so you don't actually have to run n++ as admin again after you're finished. – Ari Roth Dec 5 at 4:09
  • There is a file association issue that exists in Windows 10 April 2018 Update and Windows 10 October 2018 Update. Which has been fixed, the solution is simple, update your system. – Ramhound Dec 8 at 4:56
  • You genious! Thanx – Francesco Mantovani Dec 14 at 0:06

This took me a minute, but this should help.

  1. Find a .txt file
  2. Right click it
  3. Select "Open with..." --> "Choose another app"
  4. Scroll down and select "More Apps" on the popup
  5. Select "Look for another app on this PC..."
  6. Find and select notepad++.exe

If nothing of the above works, try using this:

https://www.binaryfortress.com/NotepadReplacer/

and then Right click on the file > Open With > Choose another app and select Notepad++

Okay, here is a work around:

  1. Create a dummy file with the extension you wish to default to your program. The file can be empty.
  2. Right click on the dummy file and select Properties.
  3. On the General tab there is a section that states: Type of file: Opens with and a button that says . Click Change.
  4. How do you want to open files from now on? Choose .
  5. Scroll to the bottom and select Go to C:\Program Files (x86)\Notepad++ and select and select
  6. Close Properties and your done!

Credits to Kent Lasley from : https://notepad-plus-plus.org/community/topic/13051/set-notepad-as-default-app-in-windows-10

  • @SherylHohman - There is a file association issue that exists in Windows 10 April 2018 Update and Windows 10 October 2018 Update. Which has been fixed, the solution is simple, update your system. – Ramhound Dec 8 at 4:56

After trying all the solutions described, this what I found, and how I made it work (kudos to SherylHohman for her comment in Animesh Chandra's answer for spurring me on).

You don't own your computer.  Microsoft does.

For some reason I thought, 'just click on the whitespace above "always use this app to open .log files"' and, lo and behold...

that's more like it

and things go back to working the way they used to.

---- edit ---- and then I find I am facing the same issue as Daniel Hári. The file reverts to opening using windows notepad (not much use, since it's an rsyncd.log file, with unix-style line endings).

so -- run regedit as administrator, and make these changes... (exporting them as .reg files results in hex output for the "ItemName". This format seems more readable). Note that the .log extension had no sub-keys on my example machine, so I did not edit that key. There are other extensions with sub-keys that may be of interest to you. I found them by searching the registry for the string txtfile .

regedit1 regedti2 regedit3

The change seems to have become more sticky (all bets are off following the next feature update).

protected by Twisty Impersonator Dec 13 at 2:40

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.