0

I have an ACTIONTEC C1900A ADSL/VDSL modem (CenturyLink branding).

The device has the most recent firmware installed (CAB005-31.30L.96).

When I telnet to the device and run the sh command to get to the shell, here's what the session looks like:

PS C:\> telnet 192.168.0.1
===Actiontec xDSL Router===
Login: admin
Password: <entered my telnet password>
> sh
Please input shell credential to login
Login:

I tried a username of admin and my telnet password, but all I get is:

Please input shell credential to login
Login:admin
Password: <entered my telnet password again>
Password Incorrect! Try again.

I also tried a username of admin and the default password of the device (on the device's sticker), but that password doesn't work either.

In other words: There are ADDITIONAL credentials to access the sh prompt on the C1900A. I don't see these additional credentials anywhere in the C1000A configuration GUI.

I have performed a reset of the C1900A device but the additional sh password is still there.

Does anyone know what credentials to use for sh console access on the CenturyLink C1900A device?

  • 1
    "latest firmware provided by CenturyLink" Clearly you should ask CenturtyLink support about this issue. – DavidPostill May 20 '18 at 17:29
  • First problem, you purchased a CenturyLink branded modem, with CenturyLink specific firmware, instead of a retail "unlocked" or unbranded version and expect full control over the product. Honestly, they may not give you that access or password, whether you own the modem or not. The only way may be to get get the firmware image and reverse engineer it, which may or may not be possible. – acejavelin May 20 '18 at 19:08
  • That may be. But I will still like to know if this is just a mistake on CenturyLink's part, or if I can find out these credentials. – Bill_Stewart May 20 '18 at 20:25

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.