14

This question already has an answer here:

I know there have been many topics about this, and believe me, I've already read dozens of them, as well as following numerous guides like this one, but no matter what I do, my Windows 10 still keeps restarting whenever it wants to install it's updates. I just step off the computer for a few minutes to get a coffee or a bathroom break, and then I come back, only to see another update going on, all my unsaved work gone. No prompts, no warnings. Sometimes it even begins restarting while I'm still working on my computer, and then I'm forced to wait, sometimes for half an hour, until it finishes the update.. I am an advanced user, and I already disabled everything in settings, services, registry, user policy, even disable update services via Task Manager, but they keep restarting themselves to do their bloody work. I even wrote a .bat script to keep disable all running update services, but the bloody 10 somehow still gets around it.

I am frustrated beyond belief. I must have already spent like 10 hours investigating this, going through guides, forums, etc., but they all suggest all too familiar steps, which I already did, and checked numerous of times.

What else can I do? Is there a way to hard-disable restart altogether, so that Windows itself is blocked from that function unless I run it manually? I am tired of fighting, and I want this auto-restart feature gone, forever.

P.S. Before you ask, my computer is clean of viruses, malware, 3rd party apps or anything else that could be related. No hardware problems, no BSOD's or anything.

P.P.S. Some people suggested that my question is a duplicate of How to disable automatic reboots in Windows 10? . However, it is not, because I have reviewed all the answers to that question, tried all the suggestions, but they were ineffective to solve the problem - Windows still restarts to install it's updates.

marked as duplicate by Run5k, Michael Frank, fixer1234, n8te, harrymc windows May 21 '18 at 6:37

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • 2
    Not a duplicate, sir. I have read that question, and followed every piece of advice in it's answers, and the problem still remains. – J R May 20 '18 at 22:23
  • 1
    First of all, Welcome to Super User! We are always glad to help, and your frustration is totally understandable. However, this is definitely a duplicate of the referenced question. – Run5k May 20 '18 at 22:27
  • 2
    So what do you suggest I do? As I said, I did every thing listed in that question you linked, but it did not solve the problem. I was hoping that someone could address that. – J R May 20 '18 at 22:30
  • 1
    We still need to keep these kinds of questions from being duplicated. What if someone answers your question here and it works, but the next person to come searching only finds the original question? They will try the solutions offered in that question, but won't see this question here with the potentially right answer for them. – Michael Frank May 21 '18 at 0:10
  • 1
    There might not be a good answer for you, but that doesn't mean that the questions are different. If you think the question is different, you need to differentiate the question (beyond stating that the answers there don't work). What about your question is substantively different from the other question? BTW, that's a canonical thread, with 11 upvoted answers and 277K views. If there were other solutions, that's where they would be, and if someone comes up with a new solution, that's where they will put it. – fixer1234 May 21 '18 at 1:14
2

Update 2: After testing, my previous update failed to be effective. Microsoft seems to have implemented features that prevent even it from working.

My final solution was to use a utility called StopUpdates10. It combines all of the techniques I've read about over the last few months, notably multiple registry changes and the disabling of multiple services—rather than just the couple that keep being mentioned but which don't work on their own.


My computer is on 24/7, as I use it to host various services.

I have my Windows Update service stopped and set to Disabled. (Only Disabled will work.) When I want to apply updates, I re-enable the service (and then check for updates manually) at a time that I can afford to have it offline. When the updates are finished, I reboot it myself. After it reboots, I stop and disable the service again.

My computer has never restarted on its own (barring crashes and power failures).

Note: I just checked, and this answer is in the other question. (Although I find the other version of the answer needlessly complicated.) Perhaps you missed it . . .


Update 1: I just discovered that my computer had rebooted—and that my Windows Update service had been re-enabled. I have never had this happen before. Perhaps something has changed in what Microsoft is doing that is circumventing even this method?

I have disabled it again, removed inheritable permissions from the Windows Update registry key, and allowed only my username to have full control over it:

Computer\HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\wuauserv

If I find next month that this has still failed to prevent updates from applying without my permission, I may try adding manual hosts entries (that point to localhost) for all DNS entries related to Windows Update. Or just rename sihclient.exe, as mentioned in the other answer here.

  • Thank you for your answer, but my Windows Update service is stopped and set to Disabled as well... And yet, the updates are still installing and rebooting my computer, without any prompt or warning. – J R May 20 '18 at 23:22
  • @JR I see. If it's not Microsoft doing it, it must be third-party software of some kind. – Jason Bassford May 21 '18 at 0:14
  • It is Microsoft's doing. There is no third party software on my PC that would make this happen. I reinstalled Windows 2 weeks ago, disabled all updates as I described, before even installing any software at all. And the updates are still rolling in. – J R May 21 '18 at 8:11
  • 1
    @JR I use this method on several W10 machines with the latest version, and it works on all of them, you have a unique issue. – Moab May 21 '18 at 22:50
  • @JR I may have just encountered the same problem that you describe. I have updated my answer with some new information. – Jason Bassford May 29 '18 at 9:54
1

Technically you can go into Task schedule and delete the Windows update scheduled task so your computer won't shutdown for updates but if you do that then you will have to do updates your self by going to start "check for updates" ... another option would be to change your active time in the by going Start>check for updates>change active hours ... That will allow you to still get automatic updates but this way it happens at 4 am when your sleeping instead of 8pm when your doing homework ... hope thats the answer your looking for GL

edit: the program Sihclient.exe is the background installer for windows updates Delete that and no more updates. IE you will lose security but your computer won't shut down for updates anymore XD

  • 2
    Sorry I forgot to mention it in my original question, but I already deleted Windows update scheduled task in Task Scheduler... As for active hours, all hours are active hours for me, because I often leave computer running overnight, rendering stuff. I don't want it EVER restarting without my say-so. – J R May 20 '18 at 21:33
  • +1 for mentioning sihclient.exe, something I haven't seen anywhere else. (Although I would probably rename it rather than delete it—so you can restore its original name when you want updates again.) – Jason Bassford May 29 '18 at 18:27

Not the answer you're looking for? Browse other questions tagged or ask your own question.