1

I typed startxfce4, but it showed the error message:

failed to set mtrr: Device not configured

process 1675: D-Bus library appears to be incorrectly set up; failed to read machine uuid: Failed

to open "/etc/machine-id": No such file or directory

See the manual page for dbus-uuidgen to forrect this issue

D-Bus not built with -rdynamic so unable to print a backtrace Abort trap (core dumped) xinit: connection to X server lost

waiting for X server to shut down failed to unset mtrr: Device not configured

How do I configure the device for mtrr?

I also tried

I also tried "cd /usr/ports/x11-wm/xfce4" so that I could type "make install clean" but it showed:

/usr/ports/x11-wm/xfce4: No such file or directory

What's wrong? I looked for a solution on the Internet with no success.

1 Answer 1

0

You have to start the D-Bus service.

Put dbus_enable=YES into /etc/rc.conf. If it does not help then run dbus-uuidgen --ensure to generate the missing /etc/machine-id.

When it comes to ports, however: you have to download the ports tree first. It shouldn't be required to build XFCE from ports to solve the /etc/machine-id problem, though.

PS This issue might go away entirely in the future when this revision is merged into FreeBSD


References:

2
  • I actually figured it out before you posted this answer. I have to enable and start dbus. I read forums.freebsd.org/threads/…. I don't know of any way to link to the exact section of the page that says "Enable and start the D-Bus daemon: sysrc dbus_enable=YES && service dbus start" May 23, 2018 at 20:35
  • @JonathanDahlin I added the link to the comment + to the pull request which is going to fix this issue forever. :) Cheers May 23, 2018 at 23:02

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .