1

I have a USB printer connected to Raspberry Pi. I also have a workstation with Linux.

I have installed CUPS on both Raspberry and workstation. I logged in to CUPS on Raspberry (https://192.168.100.16:631) and add a printer (it's name is 'pr3300'). I can print a test page from CUPS: https://192.168.100.16:631/printers/pr3300

Now I want to use this printer from workstation. So I need to add this printer to workstation's CUPS.

I log into local CUPS (https://127.0.0.1:631) go to Administration and push "Add Printer" button. I have to choose the network protocol from the list:

  • AppSocket/HP JetDirect
  • Internet Printing Protocol (https)
  • Internet Printing Protocol (ipps)
  • Backend Error Handler
  • LPD/LPR Host or Printer
  • Internet Printing Protocol (ipp)
  • Internet Printing Protocol (http)

and on the next page I have to specify connection to the printer. I specify the following address: ipp://192.168.100.16/pr3300

On the next page I have to provide PPD file for my printer, give printer a name and finally I have a printer in printer's list.

But when I try to print a test page the print job fails with description "The printer configuration is incorrect or the printer no longer exists."

On the server in /var/log/cups/error_log I see the following error:

D [22/May/2018:23:15:36 +0300] Get-Printer-Attributes ipp://192.168.100.16:631/pr3300
D [22/May/2018:23:15:36 +0300] Get-Printer-Attributes client-error-not-found: The printer or class does not exist.
D [22/May/2018:23:15:36 +0300] [Client 23] Returning IPP client-error-not-found for Get-Printer-Attributes (ipp://192.168.100.16:631/pr3300) from 192.168.100.25

CUPS on server received my request, so it's running and it's not a firewall/connection problem. I guess the problem is that I have configured the shared printer wrongly on workstation CUPS. I have tried different formats of connection URL, but result is more or less the same.

Please help!

  • Can you disconnect the Pi, resetting the printer, then try connecting to the printer from the Linux PC? You should then be able to configure the PC to enable sharing of the printer through it. – DrMoishe Pippik May 23 '18 at 0:25
  • @DrMoishePippik The thing is that Raspberry Pi is the only computer which is always turned on. So I'd like to share the printer via Raspberry Pi. – lesnik May 23 '18 at 6:43
1

The problem was with incorrect printer connection string. I tried several formats (all of them suggested in CUPS help!), but only this one works:

ipp://192.168.100.16/printers/pr3300

(previously I omitted "printers" part of the URI)

  • no port number? – Daniel_L Dec 12 '18 at 9:09
  • @Daniel_L confirmed, no port number. The connection string copy-pasted into the answer as is. – lesnik Dec 12 '18 at 16:48

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.