1

My printer is behind a router (192.168.15), which is connected to another router (192.168.1). In order for me to see the printer from the 192.168.1 router, I need to disable DHCP functionality of the 192.168.15 one. However, when I do so, nothing is able to connect to that router.

I read the manual, and it says "If you disable DHCP, remember to assign a static IP address to the Router" (P.22). So I went to the 192.168.1 router, and assigned a static IP address to the 192.168.15 router. Still same result.

Then I clicked "More info" near to the "DHCP Server" option on the setup page. It said

Enable the DHCP server if you want the router to automatically set the
IP address for each computer. Select Disable to manually assign an IP
address to each computer connected to the Router.

Now I want the printer to show up on the second router, not on this one. What am I missing? Am I supposed to assign a static IP address to the printer on the 192.168.1 router? Am I supposed to assign a static 192.168.1 address to the printer on the 192.168.15 router?

Model of my router: Linksys RTP-300

| improve this question | | | | |
  • Very unclear: "I went to the 192.168.1 router, and assigned a static IP address to the 192.168.15 router" - static IPs are assigned in the static device itself. And with which ports do you connect the two routers (LAN or WAN)? – harrymc May 23 '18 at 15:37
  • Thank you for your help. My problem was that they weren't connected LAN-to-LAN. p.s., my 192.168.1 router allows setting static IP addresses to clients. i.e., if a client refuses to take a certain IP address, then it refuses connection. I do that to ensure a static IP address, because I have to reset the 192.168.15 router every time I mess up. – Alex May 23 '18 at 16:52
1

You are attempting to double NAT, which isn't what you want when you are trying to set-up visible anything from the first sub-net. This is also referred to as "router cascading".

This is how you want it setup, which will make all computers/printers & devices "visible" from both routers. (this method is called bridging)

configuration example:

Router-1
MODE = AP
SSID = "home-net"
LAN IP address = "192.168.1.1 255.255.255.0"
DHCP-Pool = "192.168.1.2 - 192.168.1.249"
WPA2-PSK = "MyPass1234!"
security type = "AES only"
Firewall = on!
Channel-1

Router-2
MODE = AP
SSID = "home-net"
LAN IP address = "192.168.1.254 255.255.255.0"
DHCP = "disabled on this router!"
WPA2-PSK = "MyPass1234!"
security type = "AES only"
NAT & Firewall = OFF!
Channel - 6 or 11

Make sure both have the same network security settings, non-mixed, AES only, Same network keys, but on non-overlapping channels.

Make sure the router-1 is connected via LAN port to one of the LAN ports of the second router. (Router-1 lan ---> Router-2 lan)

On some model printers it will help to give it a static IP address outside of the DHCP range. you can put it at 192.168.1.250 leaving three additional addresses outside of the DHCP range for future use.
(I highly recommend doing this)

As an added bonus if you set it up this way, any wireless devices will roam between the two routers seamlessly. (This is assuming router-2 is of the wireless variety.)

That should be it. The printer should now be visible, and the wireless devices should automatically switch to the highest strength AP without dropping the connection or having to manually switch.

| improve this answer | | | | |
  • Sorry for the delay, I followed your comments and then couldn't connect to update you. :) The issue is, once I disable the DHCP server, the router simply does not assign IP addresses. I.e., nothing new can connect to it. p.s., my routers are wired, so you don't have to worry about wireless. There must be something else I must modify, to make this work. Maybe I should choose "DHCP relay"? – Alex May 23 '18 at 16:41
  • OK, thanks. The problem was that it was not connected LAN-to-LAN. – Alex May 23 '18 at 16:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.