48

I have Firefox 56, the last good version of the browser, where things I need in terms of performance, and functionality both still work. I'm not going to update, EVER. There are other browsers out there, but Firefox worked so well for scripting.

Anyhow, Firefox keeps alerting me about updates. I have turned the updates off, in about:preferences but Firefox keeps bugging me with notifications like these: No, I dont wanna update FF and this: You suck FF updates....

I don't want to keep getting bothered by notifications, how do I make them stop?

1
  • 5
    If you really want to stay on the "old" firefox (pre-quantum) why not try out Firefox ESR 52? At least that is patched and stay current (until Firefox ESR move on to Quantum which is on Firefox ESR 60 and ditch the old 52) mozilla.org/en-US/firefox/organizations
    – Darius
    May 24, 2018 at 1:34

9 Answers 9

12

From experimenting with Firefox config, just as a possible addition or alternative when solutions that have previously been suggested here are not enough.

After opening the about:config (typing about:config into the address bar and then pressing Enter), apply either or both of the following config items:

  • Search for app.update.silent, then set it to true
  • Search for app.update.url, then change it to a fake/non-existent URL

    For example, if the original is https://aus5.mozilla.org/update/6/%PRODUCT%/..., I changed it to xxxhttps://xxxaus5.mozilla.org/update/6/%PRODUCT%/...

3
  • 5
    Will this still allow manual updates? Without that url will it know where to look for updates so that I can manually request updates? Jul 22, 2019 at 17:57
  • 9
    In firefox 69 app.update.silent does not exist. Jan 30, 2020 at 22:58
  • 2
    It's also app.update.url.manual now.
    – nhooyr
    Dec 14, 2020 at 1:13
30

None of the former about:config Configuration changes work nowadays to control update behaviour

This should completely disable the Updates messages in Firefox as per today:

Method 1 - Registry change (Windows)

  • Create the following Registry Key: HKEY_LOCAL_MACHINE\Software\Policies\Mozilla\Firefox
  • Create inside, a 32-Bit DWORD DisableAppUpdate, with value 1.
  • Restart Firefox.

The following can be saved as a .reg file to apply this change:

Windows Registry Editor Version 5.00
[HKEY_LOCAL_MACHINE\Software\Policies\Mozilla\Firefox]
"DisableAppUpdate"=dword:00000001

Or execute the following line in an elevated command prompt/PowerShell:

reg ADD HKLM\SOFTWARE\Policies\Mozilla\Firefox /v DisableAppUpdate /t REG_DWORD /d 1 /f

Method 2 - Policies.json (Windows / Linux / Mac / Others)

  • Create the folder distribution at the same place the Firefox executable is located (i.e. in Windows: C:\Program Files\Mozilla Firefox\distribution\).
  • [Edit: Under MacOS, create the distribution folder under ${APPS}/Firefox.app/Contents/Resources where ${APPS} is the directory you installed Firefox in. This is usually /Applications, but the Firefox app can be installed in other locations (matter of taste mostly).]
  • Create inside, a file policies.json with this text:
{ 
    "policies": {
        "DisableAppUpdate": true
    } 
}
  • Restart Firefox.

Now under about:preferences under Updates, the following label should appear: Updates disabled by your system administrator. and under about:policies.

Other policies can be modified in this way. Check the GitHub link and the about:policies section.

If you ever, ever want the original behavior, just undo these steps.

3
  • 1
    Or more precise: ManualAppUpdateOnly?
    – schemacs
    Jul 23, 2021 at 3:52
  • 1
    Does method 1 prevent me from manually updating if I want to check for updates at any time?
    – TylerH
    Jul 24, 2021 at 16:07
  • After adding this file to /etc/firefox/policies as instructed in the link. about:policies shows that the policies are disabled. I.e. adding this file had no effect.
    – wvxvw
    Aug 4, 2021 at 11:56
10

I had the same question!

I assume that you want to completely disable the updates, otherwise you won't opt the option to disable automatically install updates option from the settings, and won't get the notification at all!

Well, actually if you truly want to disable autoupdate, you can add a policy.

To add a policy, follow the steps:

  1. Go to the firefox installation directory (for any supported OS).
  2. Create a directory called distribution.
  3. Change directory into distribution.
  4. Create a file called policies.json. And paste this code:
{
    "policies": {
        "DisableAppUpdate": true
    }
}

Save the file, and quit the editor.

  1. Restart Firefox if it's already running.
  2. To confirm, you can go to the URL about:policies and check if there's an entry like this:
Policy Name     Policy Value
DisableAppUpdate    true

After you are done, from the Menu => Help => About Nightly you get to see this: Disabled Updates

When you want to update, you may set the boolean value to false.

Reading More about Policies

For documentation, you can read the options here in about:policies#documentation. You can learn more about how to add policies here.

Hope this helps!

5
  • Save the file...wherever the hell you feel like it. These details aren't important or anything.
    – John
    Nov 4, 2019 at 4:36
  • 3
    "Save the file... wherever the hell you feel like it"? - have you tested that before commenting? I have moved the file to the default installation directory [from distribution/], and it's not working. In my system, if I miss any of the step I posted, the auto-updates are re-enabled. Nov 4, 2019 at 11:24
  • You don't even use a relative term like "profile folder". If you're going to spend the time helping people you should make the proper effort.
    – John
    Nov 5, 2019 at 12:04
  • 3
    I have said to go to the installation directory (please read the step 1 again, carefully this time) If you downloaded it to the /home/users/download folder, that's your installation directory. If you move it to /opt/firefox-abcd then that's your installation directory. Note: If you don't know what your installation directory is, go to the URL about:support and check for the update directory. By default, the update directory is your installation directory. I have written the answer in a way so that a person without any technical knowledge can follow. thanks. Nov 5, 2019 at 13:18
  • 1
    Ah, I missed that. My apologies. I was not operating on sufficient sleep.
    – John
    Nov 5, 2019 at 16:35
4

This is just extension of previous answer.

Find the user preference file, named as prefs.js, in user specific folder.

  • Windows: %AppData%\Mozilla\Firefox\Profiles\xyz.default\prefs.js
  • Linux: ~\.mozilla\firefox\xyz.default\prefs.js

Then add these following three lines. These preferences are of the boolean type. If you find any of these lines are already present, replace that with the following:

user_pref("app.update.auto", false);
user_pref("app.update.disable_button.showUpdateHistory", false);
user_pref("app.update.enabled", false);

Also if you want to remove the update URL, add these three lines. These preferences are string type:

user_pref("app.update.url", "");
user_pref("app.update.url.details", "");
user_pref("app.update.url.manual", "");

If these don't work delete/move these three files:

  1. update-settings.ini,
  2. updater.ini,
  3. updater.exe (updater in Linux).
3
  • 2
    If I delete the url how will it know where to look for updates when I run updates manually or does this eliminate my ability to manually update? Jul 22, 2019 at 18:07
  • Also in newer versions, 67 and 68 I no longer have the app.update.auto setting it is now app.update.auto.migrated and setting it to false does not persist. Jul 22, 2019 at 18:09
  • Also, go to about:support, notice the the "Update Folder" entry. Delete that directory, in case a previous check for updates populated it, and found an update. Once populated, even turning off these settings won't help, but if you delete it after doing all these settings, then even if it comes back later, the settings will take effect, and you won't get the annoying reminder.
    – Victoria
    Jan 11, 2020 at 3:16
2

For others, a simpler solution if you are just annoyed by that second type of notification, you can do this in about:config by setting app.update.doorhanger to false.

3
  • 1
    Any idea what else doorhanger effects? Jul 22, 2019 at 19:18
  • 4
    This option actually replace the small top right message with a modal window. I feel this option is even more abusive...
    – Brethlosze
    Nov 5, 2019 at 18:06
  • At the time of answering, this option did not replace the doorhanger with a modal in the version I was using. This may have been changed in an update.
    – ipetrik
    Apr 7, 2020 at 18:48
0

You have done the method via Firefox Menus (which is the about:preferences), but there are a few more below.

From about:config Menu

  • Type about:config in the address bar, then press Enter.
  • Search for the app.update.auto setting.
  • Double-click the app.update.auto option to toggle the setting.  If set to true, automatic updates are enabled.  If set to false, automatic updates are disabled.

Via prefs.js file

  • Close Firefox.

  • Navigate to the following location based on your operating system.

    • Windows XP/Vista/7/8/10 – %APPDATA%\Mozilla\Firefox
    • Unix/Linux – ~/.mozilla/
    • macOS / OS X – ~/Library/Mozilla/ or ~/Library/Application Support/
  • Open the Profiles folder.

  • Open the folder that represents the profile you would like to edit.  The name of the folder will vary.  It is usually a bunch of alphanumeric characters, followed by . and the user-visible profile name (which is default by default).

  • Open the prefs.js file with a text editor like Notepad.

  • Look for a line that contains app.update.enabled. If it doesn’t exist, add a line for it in the file and set it as desired using these examples:

    • Automatic updates enabled: user_pref("app.update.enabled", true);
    • Automatic updates disabled: user_pref("app.update.enabled", false);
  • (Save the file.)

Source: TechniPages: Enable or Disable Automatic Updates in Firefox.

2
  • in about config, app.update.auto is false, but the update alerts persist...? Ill look into those files
    – j0h
    May 24, 2018 at 19:57
  • 2
    I didn't try the js file but I can say that editing about:config does nothing: it still displays the notification (even if it doesn't install automatically the update)
    – ThePhi
    Dec 5, 2019 at 17:26
0

Alternatively to Sourav Goswami's answer you can paste into policies.json this code

{
    "policies": {
        "AppUpdateURL": "http://127.0.0.1/"
    }
}

Thus you will got message "You are using latest version of Firefox" in "About" screen.

0

Extension to Sourav Goswami's answer:

Under macOS 12.2 "Monterey" I found out that Firefox 96.0.2 replaces the carefully crafted distribution/policies.json file. This happened even if I set the permissions of this file read-only (444).

It seems, however, that if I additionally make the containing distribution directory read-only (permissions 555), then it helps a little: in this case Firefox adds some more settings to the policies.json file but at least leaves the "DisableAppUpdate": true stanza intact. OTOH the permissions of the distribution directory are reset to 755, i.e. root can write to it again.

This is what I have in my policies.json file after all this:

{
    "policies" : 
    {
        "DisableAppUpdate" : true,
        "ExtensionSettings" : 
        {
            "cloudmetering@snowsoftware.com" : 
            {
                "install_url" : "file:///opt/snow/FFCloudmetering.xpi",
                "installation_mode" : "blocked"
            }
        }
    }
}

Which is deeply disturbing, because indeed the /opt/snow directory is present on my machine, it contains a snowagent, and it's quite obvious that Firefox installed this garbage behind my back.

I am not sure I'd like to have Firefox any more on my machine. The only problem is that some websites don't work properly with Safari. But that's a topic for another thread, so I stop here.

Please feel free to comment if you saw this behaviour on other platforms. Thanks.

Update (bad pun intended): The "policies" trick doesn't work, this morning Firefox started nagging me again with its oh-so-important update. OTOH the policies.json file, which is still read-only, now contains only this:

{
        "policies" : 
        {
                "DisableAppUpdate" : true,
        }
}

at least the "snow" thingy is gone.

Second update: Firefox 98.0.1 simply deleted the distribution directory and today I was nagged yet again because 98.0.2 is now available, hooray. My next attempt to fight Mozilla was to lock both the distribution directory and the policies.json file within it with the chflags uchg <file> command. Looks good, Firefox claims that updates have been disabled by the system administration. We'll see how long that lasts.

Third update: After installing Firefox 99.0.1, this time under MacOS 11.6.3 "Big Sur" and creating the distribution/policies.json directory, all was quiet until today (2022-05-10) when I was greeted with the following message:

Restart is needed

And all this despite the Firefox Preferences settings still make me believe that updates are disabled:

Updates disabled by system administrator

No, I don't want to spend my time babysitting Firefox and ranting about it on superuser.com :-)

Desperately looking for a solution that stops these unnecessary updates.

2
  • The Firefox source code is 100% open, so you can verify if this code was from Firefox. Given the xpi extension, it's almost certainly a web extension. By default, Firefox installs several different web extensions. I tried to get their devs to just include such code as part of Firefox (instead of adding it as separate extensions), but I was told they need to do it this way (no explanation was provided). As such, I wrote a script that deletes web extensions I didn't explicitly install. It runs just before the Firefox executable starts each time Firefox is launched by the user. Jan 29 at 7:57
  • "Snow" is from snowsoftware.com, looks like it's some sort of spyware. After removal it didn't come back. @RockPaperLz-MaskitorCasket: you are right, thanks, but no thanks, I am not going to review the Firefox source code :-) I am quite busy these days. Feb 1 at 9:32
-1

renaming update.exe to update3.exe do the job

Not the answer you're looking for? Browse other questions tagged or ask your own question.