I proceeded with the instructions as per the ArchWiki page. The sudo pacman -S nvidia command had around 46 options. I went for the last one linux416-rt-nvidia-390xx-390.48-3because the version number seemed closer to the one prescribed by Nvidia (390.56) for my GPU (GeForce GT 610).

Problem: after a sudo nvidia-xconfig and reboot, X server does not open; all I see is a black screen with a blinking underscore in the top left corner.

Surprisingly, when you chroot through a live boot, the nvidia-settings work and shows the proper GPU details (but with an error loading driver in the console), but the X simply doesn't work. However, I can boot back in to X server by renaming/removing the /etc/X11/xorg.conf file through chroot/tty, however nvidia-settings cannot be executed without configuring xorg.conf accordingly.

I thought it could be the version of the nvidia package installed so wanted to go for the default option, but I don't know how to uninstall and install a different option. sudo pacman -S nvidia just re-installs the same package and sudo pacman -R nvidia returns target not found: nvidia.

How to solve this problem? How to properly config nvidia in Arch/Manjaro Linux.

  • 1
    NEVER use nvidia-xconfig and never use a monolithic /etc/X11/xorg.conf! Things should work pretty much without any configuration. Also your driver might be incompatible with the latest xorg 1.20. You might want to check /var/log/Xorg.0.log. If you want to install another driver, you should use something like pacman -S nvidia-390xx. You might want to use bash autocompletion with pacman. – cylgalad May 24 at 8:04
  • @cylgalad Thanks for the info (wonder why ArchWiki doesn't provide any warning about this). The same problem occurs with the minima configuration. The error in the logs state NVIDIA: Failed to initialize the NVIDIA kernel module., then No devices detected and no screens found(EE). Error code 1 is returned at the end. – Ébe Isaac May 24 at 9:02
  • @cylgalad I also tried your suggestion in pacman; still says target not found, bash autocomplete is not much help either, it merely shows all the executable binaries starting with nvidia- and none of them allows me to uninstall/reinstall the package. – Ébe Isaac May 24 at 9:03
  • To uninstall use pacman -R package. The error you gave isn't really informative (have you tried modprobe nvidia before starting X?), try to look at all the relevant lines that have (EE), notably those pertaining to the video driver. You might post/upload your Xorg.0.log so I can take a look at it. – cylgalad May 25 at 7:05

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.