9

When I try to drag and drop to my desktop or any folder outside of FileZilla, I get an error:

Could not determine the target of the Drag&Drop operation. Either the shell extension is not installed properly, or you didn't drop the files into an explorer window.

This was working previously, I've been using FileZilla for years. I was using it last night and it was working fine. I've tried reinstalling FileZilla, I've tried restarting the computer, I've tried re-registering the shell extension, which is a solution I found online. None of these have worked. (re-registering the shell extension, such as what's found here: How can I install filezilla's shell extension?)

It does work when I drag and drop to a folder on my computer within FileZilla (using the left local directory within the FileZilla UI).

  • You should at least edit your question to provide 1/ what windows version you are using and 2/ what filezilla version you are using. – DavidPostill May 24 '18 at 20:39
11

Drag&Drop from FileZilla remote panel to Windows Explorer requires a "copy hook" shell extension.

That kind of shell extensions got broken in Windows 10 version 1803. So all applications that rely on them were broken (not only FileZilla).

There is even an announcement on FileZilla website:

Microsoft broke the ICopyHook interface in Windows 1803. Until Microsoft fixes the bug in Windows, drag & drop from FileZilla into Explorer will not work on Windows 1803.

The bug got fixed in Windows 10 version 1809 (October 2018 update).


For some background, you can read WinSCP article on Drag&drop Shell Extension. FileZilla uses WinSCP code for drag&drop (which in turn reuses similar code from Altap Salamander). Though WinSCP has alternative methods, so there drag&drop still works, even without the extension.

protected by Community Aug 24 '18 at 16:24

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.