0

I inserted an SD memory card into a USB card reader and plugged it into my PC. I got this message:

enter image description here

I knew something's not right because I just pulled this card out my laptop's built-in SD card slot, and the card was readable there. I fired up my laptop again, and indeed, the data on this card is perfectly accessible. Then I took another USB SD reader and that, too, lets me access the files no problem.

However, it's not simply the case of reader #1 not working. It does work with other cards I tried.

What's going on? Why does the same card work in one reader but is "not formatted" in the other?

P. S. It's a FAT32 64 GB card with 64K cluster size.

  • Does your card reader even support SDXC? – Daniel B May 27 '18 at 10:52
  • If the card is not properly inserted or doesn't make good contact, Windows may give this error too. I once had a similar problem. Inserted it like 10 times, each time claiming it needed to be formatted. The 11th time, it suddenly worked. – LPChip May 27 '18 at 11:05
  • @DanielB: You must be right, that seems to be a plausible explanation. – Violet Giraffe May 27 '18 at 11:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.