0

I have a CLEVO PC and since I've owned it I've always used VirtualBox to create VMs.

Recently, I noticed that in the BIOS there is no option to disable and enable the VT-X function. So I updated the BIOS to the latest version but unfortunately the option was not added. Actually from the BIOS I can only enable the VD-T function

I took advantage to update Windows from scratch and I reinstalled my virtual machine.

Everything worked without problems, when one day he program gives me the error:

VT-x is not available (VERR_VMX_NO_VMX)

Through the "securable" app I discovered this: Screenshot

But I'm sure my processor supports the VT-X function as confirmed by Intel’s ARK:

However the Intel app on the machine itself says otherwise: Screenshot

Then I saw with CPUID that the bit of the register 0x3A of my processor is set to 1, which means if I remember correctly: activate VMXON in SMX mode.

Anyone have an idea?

FWIW, I'm using Windows 10 and a friend of mine has the same PC as mine but with no updates; I did the various tests and on its pc the CPU register bit is 5 and in fact "securable" in the hardware virtualization voice says yes so it's the BIOS update.

And I alredy turned off hyper-v, not work... In the meantime I have re-enabled the hyper-v function and I use the Windows manager to virtualize

  • Perhaps one of the patches for Meltdown or Spectre is blocking virtualization. – Gerard H. Pille May 27 '18 at 13:40
  • @GerardH.Pille Except those patches have literally nothing to do with VT-x – Ramhound May 27 '18 at 13:45
  • What version of Windows are you using? – Ramhound May 27 '18 at 13:46
  • How would you know? Microsoft suddenly turned OS? – Gerard H. Pille May 27 '18 at 13:53
  • @GerardH.Pille Meltdown and Spectre have nothing to do with virtualization. How I know isn’t relevant. – Ramhound May 27 '18 at 14:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.